Regular expression denial of service in dparse
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pyupio | dparse | before 0.5.2 | 0.5.2 | Patch available | CNA |
| — | dparse (PyPI) | before 0.5.2 | 0.5.2 | Patch available | GHSA-8fg9-p83m-x5pq |
- dparse Vendorpyupio Affected before 0.5.2 Fixed in 0.5.2 Patch available CNA
- dparse (PyPI) Vendor— Affected before 0.5.2 Fixed in 0.5.2 Patch available GHSA-8fg9-p83m-x5pq
Remediation
- Fix · CNA dparse (pyupio) Fixed in 0.5.2
- Fix · GHSA-8fg9-p83m-x5pq dparse (PyPI) Fixed in 0.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39280
- 2026-10-03 Alias added: GHSA-8fg9-p83m-x5pq
References
Patch 2
Advisory 3
Sources
- CVE-2022-39280 · CVE Program
- CVE-2022-39280 · NVD
- FIRST EPSS
- GHSA-8fg9-p83m-x5pq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences