Execution with Unnecessary Privileges in JupyterApp
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-250 and CWE-427.
Summary
Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyter_core | before 4.11.2 | 4.11.2 | Patch available | CNA |
| — | jupyter-core (PyPI) | before 4.11.2 | 4.11.2 | Patch available | GHSA-m678-f26j-3hrp |
- jupyter_core Vendorjupyterlab Affected before 4.11.2 Fixed in 4.11.2 Patch available CNA
- jupyter-core (PyPI) Vendor— Affected before 4.11.2 Fixed in 4.11.2 Patch available GHSA-m678-f26j-3hrp
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyter_core:*:*:*:*:*:*:*:* | before 4.11.2 | Vulnerable | jupyterlab |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
- cpe:2.3:a:jupyter:jupyter_core:*:*:*:*:*:*:*:* Versions before 4.11.2 Vulnerable ·jupyterlab
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA jupyter_core (jupyter) Fixed in 4.11.2
- Fix · GHSA-m678-f26j-3hrp jupyter-core (PyPI) Fixed in 4.11.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39286
- 2026-10-03 Alias added: GHSA-m678-f26j-3hrp
References
Advisory 7
Other 4
- https://github.com/jupyter/jupyter_core
- https://github.com/pypa/advisory-database/tree/main/vulns/jupyter-core/PYSEC-2022-42974.yaml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/KKMP5OXXIX2QAUNVNJZ5UEQFKDYYJVBA
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YIDN7JMLK6AOMBQI4QPSW4MBQGWQ5NIN
More jupyterlab Jupyter Core vulnerabilities
- TI-2025-21506 Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability CVSS 3.1HIGH 7.3
Sources
- CVE-2022-39286 · CVE Program
- CVE-2022-39286 · NVD
- FIRST EPSS
- GHSA-m678-f26j-3hrp · GitHub Advisory Database · CC BY 4.0
- CVE-2022-39286 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences