User enumeration in the code-based login and password reset forms
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-307 and CWE-204.
Summary
Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1. If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | 3.5.0 to before 3.5.8.2; 2.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1; 3.8.0 to before 3.8.1 | 3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1 | Patch available | CNA |
| — | getkirby/cms (Packagist) | 3.5.0 to before 3.5.8.2 | 3.5.8.2 | Patch available | GHSA-43qq-qw4x-28f8 |
| — | getkirby/cms (Packagist) | 3.6.0 to before 3.6.6.2 | 3.6.6.2 | Patch available | GHSA-43qq-qw4x-28f8 |
| — | getkirby/cms (Packagist) | 3.7.0 to before 3.7.5.1 | 3.7.5.1 | Patch available | GHSA-43qq-qw4x-28f8 |
| — | getkirby/cms (Packagist) | 3.8.0 to before 3.8.1 | 3.8.1 | Patch available | GHSA-43qq-qw4x-28f8 |
- kirby Vendorgetkirby Affected 3.5.0 to before 3.5.8.2; 2.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1; 3.8.0 to before 3.8.1 Fixed in 3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected 3.5.0 to before 3.5.8.2 Fixed in 3.5.8.2 Patch available GHSA-43qq-qw4x-28f8
- getkirby/cms (Packagist) Vendor— Affected 3.6.0 to before 3.6.6.2 Fixed in 3.6.6.2 Patch available GHSA-43qq-qw4x-28f8
- getkirby/cms (Packagist) Vendor— Affected 3.7.0 to before 3.7.5.1 Fixed in 3.7.5.1 Patch available GHSA-43qq-qw4x-28f8
- getkirby/cms (Packagist) Vendor— Affected 3.8.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-43qq-qw4x-28f8
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* | before 3.5.8.2; 3.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:-:*:*:*:*:*:* | 3.8.0 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:rc1:*:*:*:*:*:* | 3.8.0 rc1 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:rc2:*:*:*:*:*:* | 3.8.0 rc2 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:rc3:*:*:*:*:*:* | 3.8.0 rc3 | Vulnerable | getkirby |
- cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions before 3.5.8.2; 3.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:-:*:*:*:*:*:* Versions 3.8.0 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:rc1:*:*:*:*:*:* Versions 3.8.0 rc1 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:rc2:*:*:*:*:*:* Versions 3.8.0 rc2 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:rc3:*:*:*:*:*:* Versions 3.8.0 rc3 Vulnerable ·getkirby
Remediation
- Fix · CNA kirby (getkirby) Fixed in 3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1
- Fix · GHSA-43qq-qw4x-28f8 getkirby/cms (Packagist) Fixed in 3.5.8.2 Advisory →
- Fix · GHSA-43qq-qw4x-28f8 getkirby/cms (Packagist) Fixed in 3.6.6.2 Advisory →
- Fix · GHSA-43qq-qw4x-28f8 getkirby/cms (Packagist) Fixed in 3.7.5.1 Advisory →
- Fix · GHSA-43qq-qw4x-28f8 getkirby/cms (Packagist) Fixed in 3.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39314
- 2026-10-03 Alias added: GHSA-43qq-qw4x-28f8
References
Advisory 2
More getkirby Kirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2022-39314 · CVE Program
- CVE-2022-39314 · NVD
- FIRST EPSS
- GHSA-43qq-qw4x-28f8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences