Kirby CMS vulnerable to user enumeration in the brute force protection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-204.
Summary
Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 3.5.8.2; 3.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1; = 3.8.0 | 3.5.8.2, 3.6.6.2, 3.7.5.1 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 3.5.8.2 | 3.5.8.2 | Patch available | GHSA-c27j-76xg-6x4f |
| — | getkirby/cms (Packagist) | 3.6.0 to before 3.6.6.2 | 3.6.6.2 | Patch available | GHSA-c27j-76xg-6x4f |
| — | getkirby/cms (Packagist) | 3.7.0 to before 3.7.5.1 | 3.7.5.1 | Patch available | GHSA-c27j-76xg-6x4f |
| — | getkirby/cms (Packagist) | 3.8.0 to before 3.8.1 | 3.8.1 | Patch available | GHSA-c27j-76xg-6x4f |
- kirby Vendorgetkirby Affected before 3.5.8.2; 3.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1; = 3.8.0 Fixed in 3.5.8.2, 3.6.6.2, 3.7.5.1 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 3.5.8.2 Fixed in 3.5.8.2 Patch available GHSA-c27j-76xg-6x4f
- getkirby/cms (Packagist) Vendor— Affected 3.6.0 to before 3.6.6.2 Fixed in 3.6.6.2 Patch available GHSA-c27j-76xg-6x4f
- getkirby/cms (Packagist) Vendor— Affected 3.7.0 to before 3.7.5.1 Fixed in 3.7.5.1 Patch available GHSA-c27j-76xg-6x4f
- getkirby/cms (Packagist) Vendor— Affected 3.8.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-c27j-76xg-6x4f
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* | before 3.5.8.2; 3.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:-:*:*:*:*:*:* | 3.8.0 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:rc1:*:*:*:*:*:* | 3.8.0 rc1 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:rc2:*:*:*:*:*:* | 3.8.0 rc2 | Vulnerable | getkirby |
| cpe:2.3:a:getkirby:kirby:3.8.0:rc3:*:*:*:*:*:* | 3.8.0 rc3 | Vulnerable | getkirby |
- cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions before 3.5.8.2; 3.6.0 to before 3.6.6.2; 3.7.0 to before 3.7.5.1 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:-:*:*:*:*:*:* Versions 3.8.0 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:rc1:*:*:*:*:*:* Versions 3.8.0 rc1 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:rc2:*:*:*:*:*:* Versions 3.8.0 rc2 Vulnerable ·getkirby
- cpe:2.3:a:getkirby:kirby:3.8.0:rc3:*:*:*:*:*:* Versions 3.8.0 rc3 Vulnerable ·getkirby
Remediation
- Fix · CNA kirby (getkirby) Fixed in 3.5.8.2, 3.6.6.2, 3.7.5.1
- Fix · GHSA-c27j-76xg-6x4f getkirby/cms (Packagist) Fixed in 3.5.8.2 Advisory →
- Fix · GHSA-c27j-76xg-6x4f getkirby/cms (Packagist) Fixed in 3.6.6.2 Advisory →
- Fix · GHSA-c27j-76xg-6x4f getkirby/cms (Packagist) Fixed in 3.7.5.1 Advisory →
- Fix · GHSA-c27j-76xg-6x4f getkirby/cms (Packagist) Fixed in 3.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39315
- 2026-10-03 Alias added: GHSA-c27j-76xg-6x4f
- 2026-10-11 EPSS moved to the 50th–90th percentile
References
Advisory 6
- https://github.com/getkirby/kirby/security/advisories/GHSA-c27j-76xg-6x4f
- https://github.com/getkirby/kirby/releases/tag/3.5.8.2
- https://github.com/getkirby/kirby/releases/tag/3.6.6.2
- https://github.com/getkirby/kirby/releases/tag/3.7.5.1
- https://github.com/getkirby/kirby/releases/tag/3.8.1
- https://nvd.nist.gov/vuln/detail/CVE-2022-39315
More getkirby Kirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2022-39315 · CVE Program
- CVE-2022-39315 · NVD
- FIRST EPSS
- GHSA-c27j-76xg-6x4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences