@keystone-6/core vulnerable to field-level access-control bypass for multiselect field
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| keystonejs | keystone | 2.2.0 to before 2.3.1 | 2.3.1 | Patch available | CNA |
| — | @keystone-6/core (npm) | 2.2.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-6mhr-52mv-6v6f |
- keystone Vendorkeystonejs Affected 2.2.0 to before 2.3.1 Fixed in 2.3.1 Patch available CNA
- @keystone-6/core (npm) Vendor— Affected 2.2.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-6mhr-52mv-6v6f
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:keystonejs:keystone:*:*:*:*:*:node.js:*:* | 2.2.0 to before 2.3.1 | Vulnerable | keystonejs |
- cpe:2.3:a:keystonejs:keystone:*:*:*:*:*:node.js:*:* Versions 2.2.0 to before 2.3.1 Vulnerable ·keystonejs
Remediation
- Fix · CNA keystone (keystonejs) Fixed in 2.3.1
- Fix · GHSA-6mhr-52mv-6v6f @keystone-6/core (npm) Fixed in 2.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39322
- 2026-10-03 Alias added: GHSA-6mhr-52mv-6v6f
References
More keystonejs Keystone vulnerabilities
- TI-2022-18756 NODE_ENV in Keystone defaults to development with esbuild CVSS 3.1CRITICAL 9.8
- TI-2017-11626 CSV Injection (aka Excel Macro Injection or Formula Injection) exists in… CVSS 3.0HIGH 8.8
- TI-2022-11852 An arbitrary file upload vulnerability in the file upload module of Keystone v4.2.1… CVSS 3.1CRITICAL 9.8
- TI-2017-12181 KeystoneJS before 4.0.0-beta.7 allows application-wide CSRF bypass by removing the CSRF… CVSS 3.0HIGH 8.8
- TI-2015-07619 Credentials management flaw in HackerOne keystone node module CVSS 3.0HIGH 7.5
- TI-2017-11625 A cross-site scripting (XSS) vulnerability exists in… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2022-39322 · CVE Program
- CVE-2022-39322 · NVD
- FIRST EPSS
- GHSA-6mhr-52mv-6v6f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences