An issue was discovered in Gajim through 1.4.7.
Priority LOW 31CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-284.
Summary
An issue was discovered in Gajim through 1.4.7. The vulnerability allows attackers, via crafted XML stanzas, to correct messages that were not sent by them. The attacker needs to be part of the group chat or single chat. The fixed version is 1.5.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00559 46th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39835
- 2026-10-03 Alias added: GHSA-q3pp-76rw-fqvm
References
More Gajim vulnerabilities
- TI-2012-01859 SQL injection vulnerability in the get_last_conversation_lines function in… CVSS 2.0HIGH 7.5
- TI-2021-17909 Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service… CVSS 3.1HIGH 7.5
- TI-2012-01858 The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted… CVSS 2.0MEDIUM 6.8
- TI-2015-07148 Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages… CVSS 3.0MEDIUM 5.4
- TI-2016-08426 Gajim through 0.16.7 unconditionally implements the "XEP-0146: Remote Controlling… CVSS 3.0MEDIUM 4.5
- TI-2012-04643 The _ssl_verify_callback function in tls_nb.py in Gajim before 0.15.3 does not properly… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2022-39835 · CVE Program
- CVE-2022-39835 · NVD
- FIRST EPSS
- GHSA-q3pp-76rw-fqvm · GitHub Advisory Database · CC BY 4.0
- CVE-2022-39835 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences