Incorrect authorization in owasp-modsecurity ModSecurity Core Rule Set
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Will not fix Red Hat: no fix planned
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-863.
Summary
The OWASP ModSecurity Core Rule Set (CRS) is affected by a response body bypass to sequentially exfiltrate small and undetectable sections of data by repeatedly submitting an HTTP Range header field with a small byte range. A restricted resource, access to which would ordinarily be detected, may be exfiltrated from the backend, despite being protected by a web application firewall that uses CRS. Short subsections of a restricted resource may bypass pattern matching techniques and allow undetected access. The legacy CRS versions 3.0.x and 3.1.x are affected, as well as the currently supported versions 3.2.1 and 3.3.2. Integrators and users are advised to upgrade to 3.2.2 and 3.3.3 respectively and to configure a CRS paranoia level of 3 or higher.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| owasp-modsecurity | ModSecurity Core Rule Set | 3.0.x; 3.1.x; up to 3.2.1; up to 3.3.2 | — | No fix listed | CNA |
- ModSecurity Core Rule Set Vendorowasp-modsecurity Affected 3.0.x; 3.1.x; up to 3.2.1; up to 3.3.2 Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:owasp:owasp_modsecurity_core_rule_set:*:*:*:*:*:*:*:* | 3.0.0 to before 3.2.2; 3.3.0 to before 3.3.3 | Vulnerable | owasp-modsecurity |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:owasp:owasp_modsecurity_core_rule_set:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.2.2; 3.3.0 to before 3.3.3 Vulnerable ·owasp-modsecurity
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
No fixed version listed by the sources yet.
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
OWASP ModSecurity Core Rule Set — FEDORA-2022-1fd73a5285
4 records Highest priority Priority MEDIUM 4 MEDIUM
Other records, highest priority first
- TI-2022-18921 Partial rule set bypass in OWASP ModSecurity Core Rule Set by submitting a specially crafted HTTP Content-Type headerPriority MEDIUM 51
- TI-2022-18922 Incorrect authorization in owasp-modsecurity ModSecurity Core Rule SetPriority MEDIUM 50
- TI-2022-18923 Response body bypass in OWASP ModSecurity Core Rule Set via a specialy crafted charset in the HTTP Accept headerPriority MEDIUM 41
- Advisory ·
OWASP ModSecurity Core Rule Set — FEDORA-2022-90708b46e3
4 records Highest priority Priority MEDIUM 4 MEDIUM
Other records, highest priority first
- TI-2022-18921 Partial rule set bypass in OWASP ModSecurity Core Rule Set by submitting a specially crafted HTTP Content-Type headerPriority MEDIUM 51
- TI-2022-18922 Incorrect authorization in owasp-modsecurity ModSecurity Core Rule SetPriority MEDIUM 50
- TI-2022-18923 Response body bypass in OWASP ModSecurity Core Rule Set via a specialy crafted charset in the HTTP Accept headerPriority MEDIUM 41
Show 1 more group
- Advisory ·
OWASP ModSecurity Core Rule Set — FEDORA-2022-85a85c84b3
4 records Highest priority Priority MEDIUM 4 MEDIUM
Other records, highest priority first
- TI-2022-18921 Partial rule set bypass in OWASP ModSecurity Core Rule Set by submitting a specially crafted HTTP Content-Type headerPriority MEDIUM 51
- TI-2022-18922 Incorrect authorization in owasp-modsecurity ModSecurity Core Rule SetPriority MEDIUM 50
- TI-2022-18923 Response body bypass in OWASP ModSecurity Core Rule Set via a specialy crafted charset in the HTTP Accept headerPriority MEDIUM 41
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39958
- 2026-10-03 Alias added: GHSA-3m69-hv34-fc7r
References
More owasp-modsecurity Owasp Modsecurity Core Rule Set vulnerabilities
- TI-2026-17577 OWASP CRS has multipart bypass using multiple content-type parts CVSS 3.1CRITICAL 9.3
- TI-2022-18921 Partial rule set bypass in OWASP ModSecurity Core Rule Set by submitting a specially crafted HTTP Content-Type header CVSS 3.1CRITICAL 9.8
- TI-2022-18922 Incorrect authorization in owasp-modsecurity ModSecurity Core Rule Set CVSS 3.1CRITICAL 9.8
- TI-2021-14182 OWASP ModSecurity Core Rule Set 3.1.x before 3.1.2, 3.2.x before 3.2.1, and 3.3.x before… CVSS 3.1CRITICAL 9.8
- TI-2020-14375 Modsecurity owasp-modsecurity-crs 3.2.0 (Paranoia level at PL1) has a SQL injection… CVSS 3.1CRITICAL 9.8
- TI-2022-18923 Response body bypass in OWASP ModSecurity Core Rule Set via a specialy crafted charset in the HTTP Accept header CVSS 3.1HIGH 7.5
Sources
- CVE-2022-39958 · CVE Program
- CVE-2022-39958 · NVD
- FIRST EPSS
- GHSA-3m69-hv34-fc7r · GitHub Advisory Database · CC BY 4.0
- CVE-2022-39958 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences