Read the docs
TI-2022-18933 Aliases CVE-2022-39986GHSA-7c28-wg7r-pg6f

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated…

Priority CRITICAL 94CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.

Summary

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.99058 99th percentileScored 2026-11-07
Fix Fixed billz/raspap-webgui (Packagist): 2.8.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—billz/raspap-webgui (Packagist)2.8.0 to before 2.8.82.8.8Patch availableGHSA-7c28-wg7r-pg6f
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • billz/raspap-webgui (Packagist) Vendor— Affected 2.8.0 to before 2.8.8 Fixed in 2.8.8 Patch available GHSA-7c28-wg7r-pg6f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:raspap:raspap:*:*:*:*:*:*:*:*2.8.0 – 2.8.7VulnerableRaspAP
  • cpe:2.3:a:raspap:raspap:*:*:*:*:*:*:*:* Versions 2.8.0 – 2.8.7 Vulnerable ·RaspAP

Remediation

  • Fix · GHSA-7c28-wg7r-pg6f billz/raspap-webgui (Packagist) Fixed in 2.8.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-39986
  2. 2026-10-03 Alias added: GHSA-7c28-wg7r-pg6f

References

  • TI-2022-18934 A Command injection vulnerability in RaspAP 2.8.0 thru 2.9.2 allows an authenticated… CVSS 3.1HIGH 8.8
  • TI-2024-02323 RaspAP raspap-webgui HTTP POST Request provider.php code injection CVSS 3.1HIGH 7.2
  • TI-2021-12821 A vulnerability exists in RaspAP 2.6 to 2.6.5 in the "iface" GET parameter in… CVSS 3.1CRITICAL 9.8
  • TI-2021-16152 includes/configure_client.php in RaspAP 2.6.6 allows attackers to execute commands via command injection. CVSS 3.1HIGH 8.8
  • TI-2020-15053 An issue was discovered in includes/webconsole.php in RaspAP 2.5. CVSS 3.1HIGH 8.8
  • TI-2021-12820 Multiple privilege escalation vulnerabilities in RaspAP 1.5 to 2.6.5 could allow an… CVSS 3.1HIGH 8.8
See all 11 →

Sources