Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when…
Priority LOW 37CWE-1333Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 fixed, 8 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.
Summary
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
Why it matters now
EPSS 0.0232 83rd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Partial mako (PyPI): 1.2.2Red Hat: 2 advisoriesRed Hat: 2 fixed, 8 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mako (PyPI) | before 1.2.2 | 1.2.2 | Patch available | GHSA-v973-fxgf-6xhp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mako (PyPI) Vendor— Affected before 1.2.2 Fixed in 1.2.2 Patch available GHSA-v973-fxgf-6xhp
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sqlalchemy:mako:*:*:*:*:*:*:*:* | before 1.2.2 | Vulnerable | sqlalchemy |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:sqlalchemy:mako:*:*:*:*:*:*:*:* Versions before 1.2.2 Vulnerable ·sqlalchemy
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-v973-fxgf-6xhp mako (PyPI) Fixed in 1.2.2 Advisory →
Red Hat 2 advisories
- RHSA-2023:2893 Released 2023-05-16 · Red Hat rating Moderatepython-mako security update
- Red Hat Enterprise Linux AppStream (v. 8) python-mako-1.0.6-14.el8, python3-mako-1.0.6-14.el8
- RHSA-2023:2258 Released 2023-05-09 · Red Hat rating Moderatepython-mako security update
- Red Hat Enterprise Linux AppStream (v. 9) python-mako-1.1.4-6.el9, python3-mako-1.1.4-6.el9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 3 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat Openshift Container Storage 4 | Affected | No fix yet |
| Red Hat Openshift Data Foundation 4 | Affected | No fix yet |
| Red Hat Quay 3 | Affected | No fix yet |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:2893 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:2258 |
Not affected: 5 products
- Red Hat Ceph Storage 4
- Red Hat Ceph Storage 5
- Red Hat OpenStack Platform 16.1
- Red Hat OpenStack Platform 16.2
- Red Hat OpenStack Platform 17.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-40023
- 2026-10-03 Alias added: GHSA-v973-fxgf-6xhp
References
Exploit 2
Patch 2
Advisory 4
Other 5
- https://github.com/pypa/advisory-database/tree/main/vulns/mako/PYSEC-2022-260.yaml
- https://github.com/sqlalchemy/mako
- https://lists.debian.org/debian-lts-announce/2025/12/msg00004.html
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages
- https://pyup.io/vulnerabilities/CVE-2022-40023/50870
Sources
- CVE-2022-40023 · CVE Program
- CVE-2022-40023 · NVD
- FIRST EPSS
- GHSA-v973-fxgf-6xhp · GitHub Advisory Database · CC BY 4.0
- CVE-2022-40023 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences