Deserialization of untrusted data in CERT/CC VINCE - The Vulnerability Information and…
Priority MEDIUM 43CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
A Remote Code Injection vulnerability exists in CERT software prior to version 1.50.5. An authenticated attacker can inject arbitrary pickle object as part of a user's profile. This can lead to code execution on the server when the user's profile is accessed.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01483 74th percentileScored 2026-11-07
Fix Fixed VINCE - The Vulnerability Information and Coordination Environment (CERT/CC): 1.50.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CERT/CC | VINCE - The Vulnerability Information and Coordination Environment | 1.48.0 to before 1.50.5 | 1.50.5 | Patch available | CNA |
- VINCE - The Vulnerability Information and Coordination Environment VendorCERT/CC Affected 1.48.0 to before 1.50.5 Fixed in 1.50.5 Patch available CNA
Remediation
- Fix · CNA VINCE - The Vulnerability Information and Coordination Environment (CERT/CC) Fixed in 1.50.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-40238
- 2026-10-03 Alias added: GHSA-9gw9-mrm5-m5x9
References
Advisory 1
More CERT/CC Vince vulnerabilities
- TI-2024-09697 CERT/CC VINCE versions before 3.0.9 allows authenticated user to access User Management view. CVSS 3.1MEDIUM 6.5
- TI-2022-09370 An open redirect vulnerability exists in CERT/CC VINCE software prior to version 1.50.0 CVSS 3.1MEDIUM 6.1
- TI-2022-19104 An HTML injection vulnerability exists in CERT/CC VINCE software prior to version 1.50.4 CVSS 3.1MEDIUM 5.4
- TI-2022-19102 An HTML injection vulnerability exists in CERT/CC VINCE software prior to version 1.50.4 CVSS 3.1MEDIUM 5.4
- TI-2024-09236 Potential DoS Vulnerability in CERT VINCE Software Before Version 3.0.8 CVSS 3.1MEDIUM 4.9
Sources
- CVE-2022-40238 · CVE Program
- CVE-2022-40238 · NVD
- FIRST EPSS
- GHSA-9gw9-mrm5-m5x9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences