Read the docs
TI-2022-19497 Aliases CVE-2022-40954GHSA-45r6-j3cc-6mxx

Apache Airflow Spark Provider RCE that bypass restrictions to read arbitrary files

Priority LOW 28CWE-78Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Spark Provider, Apache Airflow allows an attacker to read arbtrary files in the task execution context, without write access to DAG files. This issue affects Spark Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Spark Provider is installed (Spark Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Spark Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Spark Provider installed).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0139 72nd percentileScored 2026-11-07
Fix Fixed Apache Airflow Spark Provider (Apache Software Foundation): 4.0.0Apache Airflow (Apache Software Foundation): 2.3.0+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Airflow Spark Providerbefore 4.0.04.0.0Patch availableCNA
ApacheApache Airflowbefore 2.3.02.3.0Patch availableCNA
—apache-airflow (PyPI)before 2.3.02.3.0Patch availableGHSA-45r6-j3cc-6mxx
  • Apache Airflow Spark Provider VendorApache Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
  • Apache Airflow VendorApache Affected before 2.3.0 Fixed in 2.3.0 Patch available CNA
  • apache-airflow (PyPI) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-45r6-j3cc-6mxx

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*before 2.3.0VulnerableApache
cpe:2.3:a:apache:apache-airflow-providers-apache-spark:*:*:*:*:*:*:*:*before 4.0.0VulnerableApache
  • cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* Versions before 2.3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:apache-airflow-providers-apache-spark:*:*:*:*:*:*:*:* Versions before 4.0.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Airflow Spark Provider (Apache Software Foundation) Fixed in 4.0.0
  • Fix · CNA Apache Airflow (Apache Software Foundation) Fixed in 2.3.0
  • Fix · GHSA-45r6-j3cc-6mxx apache-airflow (PyPI) Fixed in 2.3.0 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Airflow 2.3.0

    3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2022-19056 Apache Airlfow Pig Provider RCEPriority MEDIUM 56
    • TI-2022-18182 Apache Airflow Pinot provider allowed Command InjectionPriority MEDIUM 55

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-40954
  2. 2026-10-03 Alias added: GHSA-45r6-j3cc-6mxx

References

  • TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
  • TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
  • TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
  • TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
  • TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
See all 157 →

Sources