Read the docs
TI-2022-19650 Aliases CVE-2022-41131GHSA-cm43-f2pv-6v68

Apache Airflow Hive Provider vulnerability (command injection via hive_cli connection)

Priority MEDIUM 40CWE-78Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Hive Provider, Apache Airflow allows an attacker to execute arbtrary commands in the task execution context, without write access to DAG files. This issue affects Hive Provider versions prior to 4.1.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case HIve Provider is installed (Hive Provider 4.1.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the HIve Provider version 4.1.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Hive Provider installed).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01764 78th percentileScored 2026-11-07
Fix Fixed Apache Airflow Hive Provider (Apache Software Foundation): 4.1.0apache-airflow-providers-apache-hive (PyPI): 4.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Airflow Hive Providerbefore 4.1.04.1.0Patch availableCNA
ApacheApache Airflow2.3.0—No fix listedCNA
—apache-airflow-providers-apache-hive (PyPI)before 4.1.04.1.0Patch availableGHSA-cm43-f2pv-6v68
  • Apache Airflow Hive Provider VendorApache Affected before 4.1.0 Fixed in 4.1.0 Patch available CNA
  • Apache Airflow VendorApache Affected 2.3.0 Fixed in — No fix listed CNA
  • apache-airflow-providers-apache-hive (PyPI) Vendor— Affected before 4.1.0 Fixed in 4.1.0 Patch available GHSA-cm43-f2pv-6v68

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*before 2.3.0VulnerableApache
cpe:2.3:a:apache:apache-airflow-providers-apache-hive:*:*:*:*:*:*:*:*before 4.1.0VulnerableApache
  • cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* Versions before 2.3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:apache-airflow-providers-apache-hive:*:*:*:*:*:*:*:* Versions before 4.1.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Airflow Hive Provider (Apache Software Foundation) Fixed in 4.1.0
  • Fix · GHSA-cm43-f2pv-6v68 apache-airflow-providers-apache-hive (PyPI) Fixed in 4.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-41131
  2. 2026-10-03 Alias added: GHSA-cm43-f2pv-6v68

References

  • TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
  • TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
  • TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
  • TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
  • TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
See all 157 →

Sources