Cross-site scripting in Jenkins Anchore Container Image Scanner Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Anchore Container Image Scanner Plugin 1.0.24 and earlier does not escape content provided by the Anchore engine API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control API responses by Anchore engine.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00723 54th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:anchore-container-scanner (Maven): 1.0.25
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Anchore Container Image Scanner Plugin | up to 1.0.24 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:anchore-container-scanner (Maven) | before 1.0.25 | 1.0.25 | Patch available | GHSA-f2j5-w76m-3rqh |
- Jenkins Anchore Container Image Scanner Plugin VendorJenkins Affected up to 1.0.24 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:anchore-container-scanner (Maven) Vendor— Affected before 1.0.25 Fixed in 1.0.25 Patch available GHSA-f2j5-w76m-3rqh
Remediation
- Fix · GHSA-f2j5-w76m-3rqh org.jenkins-ci.plugins:anchore-container-scanner (Maven) Fixed in 1.0.25 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-41225
- 2026-10-03 Alias added: GHSA-f2j5-w76m-3rqh
References
Advisory 2
More Jenkins Anchore Container Image Scanner vulnerabilities
- TI-2019-12404 Insufficiently protected credentials in Jenkins Anchore Container Image Scanner Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-41225 · CVE Program
- CVE-2022-41225 · NVD
- FIRST EPSS
- GHSA-f2j5-w76m-3rqh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences