Read the docs
TI-2022-19819 Aliases CVE-2022-41323GHSA-qrw5-5h28-6cmg

In Django 3.2 before 3.2.16, 4.0 before 4.0.8, and 4.1 before 4.1.2, internationalized…

Priority MEDIUM 45CWE-1333Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 2 fixed, 2 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.

Summary

In Django 3.2 before 3.2.16, 4.0 before 4.0.8, and 4.1 before 4.1.2, internationalized URLs were subject to a potential denial of service attack via the locale parameter, which is treated as a regular expression.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.03751 89th percentileScored 2026-11-07
Fix Partial Django (PyPI): 3.2.16, 4.0.8, 4.1.2Red Hat: 2 advisoriesRed Hat: 2 fixed, 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—Django (PyPI)3.2 to before 3.2.163.2.16Patch availableGHSA-qrw5-5h28-6cmg
—Django (PyPI)4.0 to before 4.0.84.0.8Patch availableGHSA-qrw5-5h28-6cmg
—Django (PyPI)4.1 to before 4.1.24.1.2Patch availableGHSA-qrw5-5h28-6cmg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • Django (PyPI) Vendor— Affected 3.2 to before 3.2.16 Fixed in 3.2.16 Patch available GHSA-qrw5-5h28-6cmg
  • Django (PyPI) Vendor— Affected 4.0 to before 4.0.8 Fixed in 4.0.8 Patch available GHSA-qrw5-5h28-6cmg
  • Django (PyPI) Vendor— Affected 4.1 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-qrw5-5h28-6cmg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*3.2 to before 3.2.16; 4.0 to before 4.0.8; 4.1 to before 4.1.2Vulnerabledjangoproject
  • cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 3.2 to before 3.2.16; 4.0 to before 4.0.8; 4.1 to before 4.1.2 Vulnerable ·djangoproject

Remediation

  • Fix · GHSA-qrw5-5h28-6cmg Django (PyPI) Fixed in 3.2.16 Advisory →
  • Fix · GHSA-qrw5-5h28-6cmg Django (PyPI) Fixed in 4.0.8 Advisory →
  • Fix · GHSA-qrw5-5h28-6cmg Django (PyPI) Fixed in 4.1.2 Advisory →

Red Hat 2 advisories

  • RHSA-2023:2097 Released 2023-05-03 · Red Hat rating Important
    Satellite 6.13 Release
    • Red Hat Satellite 6.13 for RHEL 8 ansible-collection-redhat-satellite-3.9.0-2.el8sat, ansible-collection-redhat-satellite_operations-1.3.0-2.el8sat, ansible-lint-5.0.8-4.el8pc +47
  • RHSA-2023:0742 Released 2023-02-13 · Red Hat rating Low
    RHUI 4.3.0 release - Security Fixes, Bug Fixes, and Enhancements Update
    • RHUI 4 for RHEL 8 python-django-3.2.16-1.0.1.el8ui, python39-django-3.2.16-1.0.1.el8ui

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ansible Automation Platform 2AffectedNo fix yet
Red Hat Satellite 6AffectedNo fix yet
RHUI 4 for RHEL 8Fixed RHSA-2023:0742
Red Hat Satellite 6.13 for RHEL 8Fixed RHSA-2023:2097
Not affected: 8 products
  • RHUI 4 for RHEL 8
  • Red Hat Ceph Storage 3
  • Red Hat OpenStack Platform 13 (Queens)
  • Red Hat OpenStack Platform 16.1
  • Red Hat OpenStack Platform 16.2
  • Red Hat Satellite 6.13 for RHEL 8
  • Red Hat Storage 3
  • Red Hat Update Infrastructure 3 for Cloud Providers

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-41323
  2. 2026-10-03 Alias added: GHSA-qrw5-5h28-6cmg

References

  • TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
  • TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
  • TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
  • TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
  • TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
See all 156 →

Sources