Arches vulnerable to SQL Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Arches is a web platform for creating, managing, & visualizing geospatial data. Versions prior to 6.1.2, 6.2.1, and 7.1.2 are vulnerable to SQL Injection. With a carefully crafted web request, it's possible to execute certain unwanted sql statements against the database. This issue is fixed in version 7.12, 6.2.1, and 6.1.2. Users are recommended to upgrade as soon as possible. There are no workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| archesproject | arches | up to 6.1.2; 6.2.0 to before 6.2.1; 7.0.0 to before 7.1.2 | 6.2.1, 7.1.2 | Patch available | CNA |
| — | arches (PyPI) | before 6.1.2 | 6.1.2 | Patch available | GHSA-gmpq-xrxj-xh8m |
| — | arches (PyPI) | 6.2.0 to before 6.2.1 | 6.2.1 | Patch available | GHSA-gmpq-xrxj-xh8m |
| — | arches (PyPI) | 7.0.0 to before 7.2.0 | 7.2.0 | Patch available | GHSA-gmpq-xrxj-xh8m |
- arches Vendorarchesproject Affected up to 6.1.2; 6.2.0 to before 6.2.1; 7.0.0 to before 7.1.2 Fixed in 6.2.1, 7.1.2 Patch available CNA
- arches (PyPI) Vendor— Affected before 6.1.2 Fixed in 6.1.2 Patch available GHSA-gmpq-xrxj-xh8m
- arches (PyPI) Vendor— Affected 6.2.0 to before 6.2.1 Fixed in 6.2.1 Patch available GHSA-gmpq-xrxj-xh8m
- arches (PyPI) Vendor— Affected 7.0.0 to before 7.2.0 Fixed in 7.2.0 Patch available GHSA-gmpq-xrxj-xh8m
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:archesproject:arches:*:*:*:*:*:*:*:* | up to 6.1.1 | Vulnerable | archesproject |
| cpe:2.3:a:archesproject:arches:6.2.0:*:*:*:*:*:*:* | 6.2.0 | Vulnerable | archesproject |
| cpe:2.3:a:archesproject:arches:7.0.0:*:*:*:*:*:*:* | 7.0.0 | Vulnerable | archesproject |
| cpe:2.3:a:archesproject:arches:7.1.0:*:*:*:*:*:*:* | 7.1.0 | Vulnerable | archesproject |
| cpe:2.3:a:archesproject:arches:7.1.1:*:*:*:*:*:*:* | 7.1.1 | Vulnerable | archesproject |
- cpe:2.3:a:archesproject:arches:*:*:*:*:*:*:*:* Versions up to 6.1.1 Vulnerable ·archesproject
- cpe:2.3:a:archesproject:arches:6.2.0:*:*:*:*:*:*:* Versions 6.2.0 Vulnerable ·archesproject
- cpe:2.3:a:archesproject:arches:7.0.0:*:*:*:*:*:*:* Versions 7.0.0 Vulnerable ·archesproject
- cpe:2.3:a:archesproject:arches:7.1.0:*:*:*:*:*:*:* Versions 7.1.0 Vulnerable ·archesproject
- cpe:2.3:a:archesproject:arches:7.1.1:*:*:*:*:*:*:* Versions 7.1.1 Vulnerable ·archesproject
Remediation
- Fix · CNA arches (archesproject) Fixed in 6.2.1, 7.1.2
- Fix · GHSA-gmpq-xrxj-xh8m arches (PyPI) Fixed in 6.1.2 Advisory →
- Fix · GHSA-gmpq-xrxj-xh8m arches (PyPI) Fixed in 6.2.1 Advisory →
- Fix · GHSA-gmpq-xrxj-xh8m arches (PyPI) Fixed in 7.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-41892
- 2026-10-03 Alias added: GHSA-gmpq-xrxj-xh8m
References
Advisory 2
Sources
- CVE-2022-41892 · CVE Program
- CVE-2022-41892 · NVD
- FIRST EPSS
- GHSA-gmpq-xrxj-xh8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences