Zip slip in Lancet
Priority HIGH 71CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Lancet is a general utility library for the go programming language. Affected versions are subject to a ZipSlip issue when using the fileutil package to unzip files. This issue has been addressed and a fix will be included in versions 2.1.10 and 1.3.4. Users are advised to upgrade. There are no known workarounds for this issue.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00864 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed lancet (duke-git): 1.3.4, 2.1.10github.com/duke-git/lancet/v2 (Go): 2.1.10+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| duke-git | lancet | before 1.3.4; 2.0.0 to before 2.1.10 | 1.3.4, 2.1.10 | Patch available | CNA |
| — | github.com/duke-git/lancet/v2 (Go) | 2.0.0 to before 2.1.10 | 2.1.10 | Patch available | GHSA-pp3f-xrw5-q5j4 |
| — | github.com/duke-git/lancet (Go) | before 1.3.4 | 1.3.4 | Patch available | GHSA-pp3f-xrw5-q5j4 |
- lancet Vendorduke-git Affected before 1.3.4; 2.0.0 to before 2.1.10 Fixed in 1.3.4, 2.1.10 Patch available CNA
- github.com/duke-git/lancet/v2 (Go) Vendor— Affected 2.0.0 to before 2.1.10 Fixed in 2.1.10 Patch available GHSA-pp3f-xrw5-q5j4
- github.com/duke-git/lancet (Go) Vendor— Affected before 1.3.4 Fixed in 1.3.4 Patch available GHSA-pp3f-xrw5-q5j4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lancet_project:lancet:*:*:*:*:*:go:*:* | before 1.3.4; 2.0.0 to before 2.1.10 | Vulnerable | Lancet Project |
- cpe:2.3:a:lancet_project:lancet:*:*:*:*:*:go:*:* Versions before 1.3.4; 2.0.0 to before 2.1.10 Vulnerable ·Lancet Project
Remediation
- Fix · CNA lancet (duke-git) Fixed in 1.3.4, 2.1.10
- Fix · GHSA-pp3f-xrw5-q5j4 github.com/duke-git/lancet/v2 (Go) Fixed in 2.1.10 Advisory →
- Fix · GHSA-pp3f-xrw5-q5j4 github.com/duke-git/lancet (Go) Fixed in 1.3.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-41920
- 2026-10-03 Alias added: GHSA-pp3f-xrw5-q5j4
References
Patch 2
Advisory 2
More duke-git vulnerabilities
- TI-2026-73456 Server-side request forgery protection bypass in Lancet CVSS 4.0MEDIUM 6.3
Sources
- CVE-2022-41920 · CVE Program
- CVE-2022-41920 · NVD
- FIRST EPSS
- GHSA-pp3f-xrw5-q5j4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences