Grails Spring Security Core plugin vulnerable to privilege escalation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269 and CWE-863.
Summary
Grails Spring Security Core plugin is vulnerable to privilege escalation. The vulnerability allows an attacker access to one endpoint (i.e. the targeted endpoint) using the authorization requirements of a different endpoint (i.e. the donor endpoint). In some Grails framework applications, access to the targeted endpoint will be granted based on meeting the authorization requirements of the donor endpoint, which can result in a privilege escalation attack. This vulnerability has been patched in grails-spring-security-core versions 3.3.2, 4.0.5 and 5.1.1. Impacted Applications: Grails Spring Security Core plugin versions: 1.x 2.x >=3.0.0 <3.3.2 >=4.0.0 <4.0.5 >=5.0.0 <5.1.1 We strongly suggest that all Grails framework applications using the Grails Spring Security Core plugin be updated to a patched release of the plugin. Workarounds: Users should create a subclass extending one of the following classes from the `grails.plugin.springsecurity.web.access.intercept` package, depending on their security configuration: * `AnnotationFilterInvocationDefinition` * `InterceptUrlMapFilterInvocationDefinition` * `RequestmapFilterInvocationDefinition` In each case, the subclass should override the `calculateUri` method like so: ``` @Override protected String calculateUri(HttpServletRequest request) { UrlPathHelper.defaultInstance.getRequestUri(request) } ``` This should be considered a temporary measure, as the patched versions of grails-spring-security-core deprecates the `calculateUri` method. Once upgraded to a patched version of the plugin, this workaround is no longer needed. The workaround is especially important for version 2.x, as no patch is available version 2.x of the GSSC plugin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| grails | grails-spring-security-core | 5.0.0 to before 5.1.1; 4.0.0 to before 4.0.5; 3.0.0 to before 3.3.2; = 2.0.0 | 5.1.1, 4.0.5, 3.3.2 | Patch available | CNA |
- grails-spring-security-core Vendorgrails Affected 5.0.0 to before 5.1.1; 4.0.0 to before 4.0.5; 3.0.0 to before 3.3.2; = 2.0.0 Fixed in 5.1.1, 4.0.5, 3.3.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:grails:spring_security_core:*:*:*:*:*:grails:*:* | 1.0 to before 3.3.2; 4.0.0 to before 4.0.5; 5.0.0 to before 5.1.1 | Vulnerable | grails |
- cpe:2.3:a:grails:spring_security_core:*:*:*:*:*:grails:*:* Versions 1.0 to before 3.3.2; 4.0.0 to before 4.0.5; 5.0.0 to before 5.1.1 Vulnerable ·grails
Remediation
- Fix · CNA grails-spring-security-core (grails) Fixed in 5.1.1, 4.0.5, 3.3.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-41923
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences