mfa/FIDO2.py in django-mfa2 before 2.5.1 and 2.6.x before 2.6.1 allows a replay attack…
Priority MEDIUM 42CWE-294Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-294.
Summary
mfa/FIDO2.py in django-mfa2 before 2.5.1 and 2.6.x before 2.6.1 allows a replay attack that could be used to register another device for a user. The device registration challenge is not invalidated after usage.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01507 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed django-mfa2 (PyPI): 2.5.1, 2.6.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | django-mfa2 (PyPI) | before 2.5.1 | 2.5.1 | Patch available | GHSA-vw39-2wj9-4q86 |
| — | django-mfa2 (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-vw39-2wj9-4q86 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- django-mfa2 (PyPI) Vendor— Affected before 2.5.1 Fixed in 2.5.1 Patch available GHSA-vw39-2wj9-4q86
- django-mfa2 (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-vw39-2wj9-4q86
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:django-mfa2_project:django-mfa2:*:*:*:*:*:*:*:* | before 2.5.1; 2.6.0 to before 2.6.1 | Vulnerable | Django-mfa2 Project |
- cpe:2.3:a:django-mfa2_project:django-mfa2:*:*:*:*:*:*:*:* Versions before 2.5.1; 2.6.0 to before 2.6.1 Vulnerable ·Django-mfa2 Project
Remediation
- Fix · GHSA-vw39-2wj9-4q86 django-mfa2 (PyPI) Fixed in 2.5.1 Advisory →
- Fix · GHSA-vw39-2wj9-4q86 django-mfa2 (PyPI) Fixed in 2.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-42731
- 2026-10-03 Alias added: GHSA-vw39-2wj9-4q86
References
Advisory 3
Other 4
- https://github.com/mkalioby/django-mfa2/commit/54db5a513bcafa97a36e9f6dfa31d3c61fa8217b
- https://github.com/mkalioby/django-mfa2/commit/5fbb505e98ecdd409330a5c336ad5ec49631b0db
- https://github.com/mkalioby/django-mfa2
- https://github.com/pypa/advisory-database/tree/main/vulns/django-mfa2/PYSEC-2022-303.yaml
Sources
- CVE-2022-42731 · CVE Program
- CVE-2022-42731 · NVD
- FIRST EPSS
- GHSA-vw39-2wj9-4q86 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences