Protection mechanism failure in Jenkins Pipeline: Groovy Libraries Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-693.
Summary
A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Libraries Plugin 612.v84da_9c54906d and earlier allows attackers with permission to define untrusted Pipeline libraries and to define and run sandboxed scripts, including Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Groovy Libraries Plugin | up to 612.v84da_9c54906d | 593.595.vfc6485d13dcd | Patch available | CNA |
| — | io.jenkins.plugins:pipeline-groovy-lib (Maven) | before 613.v9c41a_160233f | 613.v9c41a_160233f | Patch available | GHSA-4hjj-9gp7-4frg |
| — | org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) | before 588.v576c103a_ff86 | 588.v576c103a_ff86 | Patch available | GHSA-4hjj-9gp7-4frg |
- Jenkins Pipeline: Groovy Libraries Plugin VendorJenkins Affected up to 612.v84da_9c54906d Fixed in 593.595.vfc6485d13dcd Patch available CNA
- io.jenkins.plugins:pipeline-groovy-lib (Maven) Vendor— Affected before 613.v9c41a_160233f Fixed in 613.v9c41a_160233f Patch available GHSA-4hjj-9gp7-4frg
- org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Vendor— Affected before 588.v576c103a_ff86 Fixed in 588.v576c103a_ff86 Patch available GHSA-4hjj-9gp7-4frg
Remediation
- Fix · CNA Jenkins Pipeline: Groovy Libraries Plugin (Jenkins project) Fixed in 593.595.vfc6485d13dcd
- Fix · GHSA-4hjj-9gp7-4frg io.jenkins.plugins:pipeline-groovy-lib (Maven) Fixed in 613.v9c41a_160233f Advisory →
- Fix · GHSA-4hjj-9gp7-4frg org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Fixed in 588.v576c103a_ff86 Advisory →
Red Hat 4 advisories
- RHSA-2023:3198 Released 2023-05-17 · Red Hat rating Criticaljenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 jenkins-2-plugins-4.11.1683009941-1.el8, jenkins-2.387.1.1683009763-3.el8
- RHSA-2023:1064 Released 2023-03-06 · Red Hat rating CriticalOpenShift Developer Tools and Services for OCP 4.12 security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1675702407-1.el8
- RHSA-2023:0777 Released 2023-02-23 · Red Hat rating CriticalOpenShift Container Platform 4.9.56 security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1675668922-1.el8, jenkins-2.361.1.1675668150-1.el8
Show 1 more Red Hat advisories
- RHSA-2023:0560 Released 2023-02-08 · Red Hat rating CriticalOpenShift Container Platform 4.10.51 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1675144701-1.el8
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 | Fixed | RHSA-2023:3198 |
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2023:1064 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:0560 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2023:0777 |
Not affected: 4 products
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8
- OpenShift Developer Tools and Services for OCP 4.12
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43405
- 2026-10-03 Alias added: GHSA-4hjj-9gp7-4frg
References
More Jenkins Groovy Libraries vulnerabilities
- TI-2022-21201 Protection mechanism failure in Jenkins Pipeline: Deprecated Groovy Libraries Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-43405 · CVE Program
- CVE-2022-43405 · NVD
- FIRST EPSS
- GHSA-4hjj-9gp7-4frg · GitHub Advisory Database · CC BY 4.0
- CVE-2022-43405 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences