Read the docs
TI-2022-21211 Aliases CVE-2022-43416GHSA-q6f6-6c4p-xph4

Code injection in Jenkins Katalon Plugin

Priority MEDIUM 43CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution, Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94 and CWE-693.

Summary

Jenkins Katalon Plugin 1.0.32 and earlier implements an agent/controller message that does not limit where it can be executed and allows invoking Katalon with configurable arguments, allowing attackers able to control agent processes to invoke Katalon on the Jenkins controller with attacker-controlled version, install location, and arguments, and attackers additionally able to create files on the Jenkins controller (e.g., attackers with Item/Configure permission could archive artifacts) to invoke arbitrary OS commands.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01345 71st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:katalon (Maven): 1.0.33

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Katalon Pluginup to 1.0.32—No fix listedCNA
—org.jenkins-ci.plugins:katalon (Maven)before 1.0.331.0.33Patch availableGHSA-q6f6-6c4p-xph4
  • Jenkins Katalon Plugin VendorJenkins Affected up to 1.0.32 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:katalon (Maven) Vendor— Affected before 1.0.33 Fixed in 1.0.33 Patch available GHSA-q6f6-6c4p-xph4

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:katalon:*:*:*:*:*:jenkins:*:*before 1.0.33VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.303.2Running onJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.318Running onJenkins
  • cpe:2.3:a:jenkins:katalon:*:*:*:*:*:jenkins:*:* Versions before 1.0.33 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.303.2 Running on ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.318 Running on ·Jenkins

Remediation

  • Fix · GHSA-q6f6-6c4p-xph4 org.jenkins-ci.plugins:katalon (Maven) Fixed in 1.0.33 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-43416
  2. 2026-10-03 Alias added: GHSA-q6f6-6c4p-xph4

References

  • TI-2022-21214 Insufficiently protected credentials in Jenkins Katalon Plugin CVSS 3.1MEDIUM 6.5
  • TI-2022-21213 Cross-site request forgery in Jenkins Katalon Plugin CVSS 3.1MEDIUM 4.3
  • TI-2022-21212 Missing authorization in Jenkins Katalon Plugin CVSS 3.1MEDIUM 4.3

Sources