Read the docs
TI-2022-21219 Aliases CVE-2022-43424GHSA-mfcw-83qg-4vw3

Protection mechanism failure in Jenkins Compuware Xpediter Code Coverage Plugin

Priority LOW 31CWE-693Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-693.

Summary

Jenkins Compuware Xpediter Code Coverage Plugin 1.0.7 and earlier implements an agent/controller message that does not limit where it can be executed, allowing attackers able to control agent processes to obtain the values of Java system properties from the Jenkins controller process.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00799 56th percentileScored 2026-11-07
Fix Fixed com.compuware.jenkins:compuware-xpediter-code-coverage (Maven): 1.0.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Compuware Xpediter Code Coverage Pluginup to 1.0.7—No fix listedCNA
—com.compuware.jenkins:compuware-xpediter-code-coverage (Maven)before 1.0.81.0.8Patch availableGHSA-mfcw-83qg-4vw3
  • Jenkins Compuware Xpediter Code Coverage Plugin VendorJenkins Affected up to 1.0.7 Fixed in — No fix listed CNA
  • com.compuware.jenkins:compuware-xpediter-code-coverage (Maven) Vendor— Affected before 1.0.8 Fixed in 1.0.8 Patch available GHSA-mfcw-83qg-4vw3

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:compuware_xpediter_code_coverage:*:*:*:*:*:jenkins:*:*before 1.0.8VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.303.2Running onJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.318Running onJenkins
  • cpe:2.3:a:jenkins:compuware_xpediter_code_coverage:*:*:*:*:*:jenkins:*:* Versions before 1.0.8 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.303.2 Running on ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.318 Running on ·Jenkins

Remediation

  • Fix · GHSA-mfcw-83qg-4vw3 com.compuware.jenkins:compuware-xpediter-code-coverage (Maven) Fixed in 1.0.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-43424
  2. 2026-10-03 Alias added: GHSA-mfcw-83qg-4vw3

References

  • TI-2022-17112 Missing authorization in Jenkins Compuware Xpediter Code Coverage Plugin CVSS 3.1MEDIUM 4.3

Sources