Read the docs
TI-2022-21242 Aliases CVE-2022-43450GHSA-3j4h-62vw-5645

WordPress Stream Plugin <= 3.9.2 is vulnerable to Insecure Direct Object References (IDOR)

Priority LOW 30CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-639.

Summary

Authorization Bypass Through User-Controlled Key vulnerability in XWP Stream.This issue affects Stream: from n/a through 3.9.2.

Why it matters now

EPSS 0.00652 51st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
xwpStreamup to 3.9.2—No fix listedCNA
  • Stream Vendorxwp Affected up to 3.9.2 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:xwp:stream:*:*:*:*:*:wordpress:*:*up to 3.9.2Vulnerablexwp
  • cpe:2.3:a:xwp:stream:*:*:*:*:*:wordpress:*:* Versions up to 3.9.2 Vulnerable ·xwp

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-43450
  2. 2026-10-03 Alias added: GHSA-3j4h-62vw-5645
  3. 2026-10-14 EPSS moved to the 50th–90th percentile

References

  • TI-2022-04015 Stream < 3.9.2 - Subscriber+ Alert Creation CVSS 3.1MEDIUM 6.5
  • TI-2021-07054 Stream < 3.8.2 - Admin+ SQL Injection CVSS 3.1HIGH 8.8
  • TI-2024-06879 Stream <= 4.0.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2022-21279 WordPress Stream Plugin <= 3.9.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8

Sources