A remote code execution vulnerability in EdgeRouters (Version 2.0.9-hotfix.4 and earlier)…
Priority MEDIUM 42CWE-250Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-250.
Summary
A remote code execution vulnerability in EdgeRouters (Version 2.0.9-hotfix.4 and earlier) allows a malicious actor with an operator account to run arbitrary administrator commands.This vulnerability is fixed in Version 2.0.9-hotfix.5 and later.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0114 66th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | EdgeMAX EdgeRouter | Fixed Version: 2.0.9-hotfix.5 or later. | — | No fix listed | CNA |
- EdgeMAX EdgeRouter Vendor— Affected Fixed Version: 2.0.9-hotfix.5 or later. Fixed in — No fix listed CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:ui:edgemax_edgerouter_firmware:*:*:*:*:*:*:*:* | before 2.0.9 | Vulnerable | Ubiquiti |
| cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:-:*:*:*:*:*:* | 2.0.9 | Vulnerable | Ubiquiti |
| cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:hotfix1:*:*:*:*:*:* | 2.0.9 hotfix1 | Vulnerable | Ubiquiti |
| cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:hotfix2:*:*:*:*:*:* | 2.0.9 hotfix2 | Vulnerable | Ubiquiti |
| cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:hotfix4:*:*:*:*:*:* | 2.0.9 hotfix4 | Vulnerable | Ubiquiti |
| cpe:2.3:h:ui:edgemax_edgerouter:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
- cpe:2.3:o:ui:edgemax_edgerouter_firmware:*:*:*:*:*:*:*:* Versions before 2.0.9 Vulnerable ·Ubiquiti
- cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:-:*:*:*:*:*:* Versions 2.0.9 Vulnerable ·Ubiquiti
- cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:hotfix1:*:*:*:*:*:* Versions 2.0.9 hotfix1 Vulnerable ·Ubiquiti
- cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:hotfix2:*:*:*:*:*:* Versions 2.0.9 hotfix2 Vulnerable ·Ubiquiti
- cpe:2.3:o:ui:edgemax_edgerouter_firmware:2.0.9:hotfix4:*:*:*:*:*:* Versions 2.0.9 hotfix4 Vulnerable ·Ubiquiti
- cpe:2.3:h:ui:edgemax_edgerouter:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43553
- 2026-10-03 Alias added: GHSA-82vg-p6h3-hr69
References
More Ubiquiti Edgemax Edgerouter Firmware vulnerabilities
- TI-2023-02228 Ubiquiti EdgeRouter X Web Management command injection CVSS 4.0HIGH 8.6
- TI-2021-05770 Improper certificate validation in EdgeMAX EdgeRouter CVSS 3.1HIGH 7.5
- TI-2023-15306 Buffer overflow in Ubiquiti EdgeRouter CVSS 3.1HIGH 7.5
Sources
- CVE-2022-43553 · CVE Program
- CVE-2022-43553 · NVD
- FIRST EPSS
- GHSA-82vg-p6h3-hr69 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences