Rancher/Wrangler: Denial of service when processing Git credentials
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | Rancher | wrangler – 0.7.3 | — | No fix listed | CNA |
| — | github.com/rancher/wrangler (Go) | before 0.7.4-security1 | 0.7.4-security1 | Patch available | GHSA-8fcj-gf77-47mg |
| — | github.com/rancher/wrangler (Go) | 0.8.0 to before 0.8.5-security1 | 0.8.5-security1 | Patch available | GHSA-8fcj-gf77-47mg |
| — | github.com/rancher/wrangler (Go) | 1.0.0 to before 1.0.1 | 1.0.1 | Patch available | GHSA-8fcj-gf77-47mg |
| — | github.com/rancher/wrangler (Go) | 0.8.6 to before 0.8.11 | 0.8.11 | Patch available | GHSA-8fcj-gf77-47mg |
- Rancher VendorSUSE Affected wrangler – 0.7.3 Fixed in — No fix listed CNA
- github.com/rancher/wrangler (Go) Vendor— Affected before 0.7.4-security1 Fixed in 0.7.4-security1 Patch available GHSA-8fcj-gf77-47mg
- github.com/rancher/wrangler (Go) Vendor— Affected 0.8.0 to before 0.8.5-security1 Fixed in 0.8.5-security1 Patch available GHSA-8fcj-gf77-47mg
- github.com/rancher/wrangler (Go) Vendor— Affected 1.0.0 to before 1.0.1 Fixed in 1.0.1 Patch available GHSA-8fcj-gf77-47mg
- github.com/rancher/wrangler (Go) Vendor— Affected 0.8.6 to before 0.8.11 Fixed in 0.8.11 Patch available GHSA-8fcj-gf77-47mg
Remediation
- Fix · GHSA-8fcj-gf77-47mg github.com/rancher/wrangler (Go) Fixed in 0.7.4-security1 Advisory →
- Fix · GHSA-8fcj-gf77-47mg github.com/rancher/wrangler (Go) Fixed in 0.8.5-security1 Advisory →
- Fix · GHSA-8fcj-gf77-47mg github.com/rancher/wrangler (Go) Fixed in 1.0.1 Advisory →
- Fix · GHSA-8fcj-gf77-47mg github.com/rancher/wrangler (Go) Fixed in 0.8.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43756
- 2026-10-03 Alias added: GHSA-8fcj-gf77-47mg
References
Advisory 2
Other 6
- https://bugzilla.suse.com/show_bug.cgi?id=1205296
- https://github.com/rancher/wrangler/security/advisories/GHSA-8fcj-gf77-47mg
- https://github.com/rancher/wrangler/commit/341018c8fef3e12867c7cb2649bd2cecac75f287
- https://github.com/rancher/rancher/security/policy
- https://github.com/rancher/wrangler
- https://pkg.go.dev/vuln/GO-2023-1515
More SUSE Wrangler vulnerabilities
- TI-2022-13282 [RANCHER] OS command injection in Rancher and Fleet CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-43756 · CVE Program
- CVE-2022-43756 · NVD
- FIRST EPSS
- GHSA-8fcj-gf77-47mg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences