ff4j 1.8.1 is vulnerable to Remote Code Execution (RCE).
Priority HIGH 82CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
ff4j 1.8.1 is vulnerable to Remote Code Execution (RCE).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01634 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.ff4j:ff4j-core (Maven): 1.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.ff4j:ff4j-core (Maven) | 1.8.1 to before 1.9 | 1.9 | Patch available | GHSA-65hj-9ppw-77xc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.ff4j:ff4j-core (Maven) Vendor— Affected 1.8.1 to before 1.9 Fixed in 1.9 Patch available GHSA-65hj-9ppw-77xc
Remediation
- Fix · GHSA-65hj-9ppw-77xc org.ff4j:ff4j-core (Maven) Fixed in 1.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-44262
- 2026-10-03 Alias added: GHSA-65hj-9ppw-77xc
References
Sources
- CVE-2022-44262 · CVE Program
- CVE-2022-44262 · NVD
- FIRST EPSS
- GHSA-65hj-9ppw-77xc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences