Resque Scheduler version 1.27.4 is vulnerable to Cross-site scripting (XSS).
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Resque Scheduler version 1.27.4 is vulnerable to Cross-site scripting (XSS). A remote attacker could inject javascript code to the "{schedule_job}" or "args" parameter in /resque/delayed/jobs/{schedule_job}?args={args_id} to execute javascript at client side.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00654 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed resque-scheduler (RubyGems): 4.10.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | resque-scheduler (RubyGems) | 1.27.4 to before 4.10.2 | 4.10.2 | Patch available | GHSA-9hmq-fm33-x4xx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- resque-scheduler (RubyGems) Vendor— Affected 1.27.4 to before 4.10.2 Fixed in 4.10.2 Patch available GHSA-9hmq-fm33-x4xx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:resque-scheduler_project:resque-scheduler:-:*:*:*:*:ruby:*:* | not specified by NVD | Vulnerable | Resque-scheduler Project |
- cpe:2.3:a:resque-scheduler_project:resque-scheduler:-:*:*:*:*:ruby:*:* Versions not specified by NVD Vulnerable ·Resque-scheduler Project
Remediation
- Fix · GHSA-9hmq-fm33-x4xx resque-scheduler (RubyGems) Fixed in 4.10.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-44303
- 2026-10-03 Alias added: GHSA-9hmq-fm33-x4xx
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
Exploit 1
Sources
- CVE-2022-44303 · CVE Program
- CVE-2022-44303 · NVD
- FIRST EPSS
- GHSA-9hmq-fm33-x4xx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences