Uploading workflows to KNIME Server may override arbitrary file system contents
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A directory traversal vulnerability in the ZIP archive extraction routines of KNIME Server since 4.3.0 can result in arbitrary files being overwritten on the server's file system. This vulnerability is also known as 'Zip-Slip'. An attacker can create a KNIME workflow that, when being uploaded, can overwrite arbitrary files that the operating system user running the KNIME Server process has write access to. The user must be authenticated and have permissions to upload files to KNIME Server. This can impact data integrity (file contents are changed) or cause errors in other software (vital files being corrupted). It can even lead to remote code execution if executable files are being replaced and subsequently executed by the KNIME Server process user. In all cases the attacker has to know the location of files on the server's file system, though. Note that users that have permissions to upload workflows usually also have permissions to run them on the KNIME Server and can therefore already execute arbitrary code in the context of the KNIME Executor's operating system user. There is no workaround to prevent this vulnerability from being exploited. Updates to fixed versions 4.13.6, 4.14.3, or 4.15.3 are advised.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| KNIME | KNIME Server | 4.15.0 to before 4.15.3; 4.14.0 to before 4.14.3; 4.3.0 to before 4.13.6 | 4.15.3, 4.14.3, 4.13.6 | Patch available | CNA |
- KNIME Server VendorKNIME Affected 4.15.0 to before 4.15.3; 4.14.0 to before 4.14.3; 4.3.0 to before 4.13.6 Fixed in 4.15.3, 4.14.3, 4.13.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:knime:knime_server:*:*:*:*:*:*:*:* | 4.3.0 to before 4.13.6; 4.14.0 to before 4.14.3; 4.15.0 to before 4.15.3 | Vulnerable | KNIME |
- cpe:2.3:a:knime:knime_server:*:*:*:*:*:*:*:* Versions 4.3.0 to before 4.13.6; 4.14.0 to before 4.14.3; 4.15.0 to before 4.15.3 Vulnerable ·KNIME
Remediation
- Fix · CNA KNIME Server (KNIME) Fixed in 4.15.3, 4.14.3, 4.13.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-44748
- 2026-10-03 Alias added: GHSA-29c9-qmhw-f6px
References
More Knime Server vulnerabilities
- TI-2021-20243 KNIME Server before 4.13.4 allows XSS via the old WebPortal login page. CVSS 3.1HIGH 8.8
- TI-2021-20242 KNIME Server before 4.13.4 allows directory traversal in a request for a client profile. CVSS 3.1HIGH 7.5
- TI-2021-20429 KNIME Server before 4.12.6 and 4.13.x before 4.13.4 (when installed in unattended mode)… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2022-44748 · CVE Program
- CVE-2022-44748 · NVD
- FIRST EPSS
- GHSA-29c9-qmhw-f6px · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences