Apache Sling Engine: Include-based XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power. Please update to Apache Sling Engine >= 2.14.0 and enable the "Check Content-Type overrides" configuration option.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Sling Engine | to before 2.14.0 | 2.14.0 | Patch available | CNA |
| — | org.apache.sling:org.apache.sling.engine (Maven) | before 2.14.0 | 2.14.0 | Patch available | GHSA-mg46-f9h5-g27x |
- Apache Sling Engine VendorApache Affected to before 2.14.0 Fixed in 2.14.0 Patch available CNA
- org.apache.sling:org.apache.sling.engine (Maven) Vendor— Affected before 2.14.0 Fixed in 2.14.0 Patch available GHSA-mg46-f9h5-g27x
Remediation
- Fix · CNA Apache Sling Engine (Apache Software Foundation) Fixed in 2.14.0
- Fix · GHSA-mg46-f9h5-g27x org.apache.sling:org.apache.sling.engine (Maven) Fixed in 2.14.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-45064
- 2026-10-03 Alias added: GHSA-mg46-f9h5-g27x
References
Sources
- CVE-2022-45064 · CVE Program
- CVE-2022-45064 · NVD
- FIRST EPSS
- GHSA-mg46-f9h5-g27x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences