Insufficiently protected credentials in Jenkins Reverse Proxy Auth Plugin
Priority LOW 30CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Reverse Proxy Auth Plugin 1.7.3 and earlier stores the LDAP manager password unencrypted in the global config.xml file on the Jenkins controller where it can be viewed by attackers with access to the Jenkins controller file system.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00717 54th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:reverse-proxy-auth-plugin (Maven): 1.7.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Reverse Proxy Auth Plugin | up to 1.7.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:reverse-proxy-auth-plugin (Maven) | 1.7.3 to before 1.7.4 | 1.7.4 | Patch available | GHSA-wcjj-qm5v-j4pc |
- Jenkins Reverse Proxy Auth Plugin VendorJenkins Affected up to 1.7.3 Fixed in — No fix listed CNA
- org.jenkins-ci.main:reverse-proxy-auth-plugin (Maven) Vendor— Affected 1.7.3 to before 1.7.4 Fixed in 1.7.4 Patch available GHSA-wcjj-qm5v-j4pc
Remediation
- Fix · GHSA-wcjj-qm5v-j4pc org.jenkins-ci.main:reverse-proxy-auth-plugin (Maven) Fixed in 1.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-45384
- 2026-10-03 Alias added: GHSA-wcjj-qm5v-j4pc
References
More Jenkins Reverse Proxy Auth vulnerabilities
- TI-2023-16175 Cross-site request forgery in Jenkins Reverse Proxy Auth Plugin CVSS 3.1HIGH 8.8
- TI-2018-15802 An exposure of sensitive information vulnerability exists in Jenkins Reverse Proxy Auth… CVSS 3.0LOW 3.3
Sources
- CVE-2022-45384 · CVE Program
- CVE-2022-45384 · NVD
- FIRST EPSS
- GHSA-wcjj-qm5v-j4pc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences