Read the docs
TI-2022-22795 Aliases CVE-2022-46151

Reflected XSS in pinterest querybook

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Querybook is an open source data querying UI. In affected versions user provided data is not escaped in the error field of the auth callback url in `querybook/server/app/auth/oauth_auth.py` and `querybook/server/app/auth/okta_auth.py`. This may allow attackers to perform reflected cross site scripting (XSS) if Content Security Policy (CSP) is not enabled or `unsafe-inline` is allowed. Users are advised to upgrade to the latest, patched version of querybook (version 3.14.2 or greater). Users unable to upgrade may enable CSP and not allow unsafe-inline or manually escape query parameters in a reverse proxy.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0045 39th percentileScored 2026-11-07
Fix Fixed querybook (pinterest): 3.14.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
pinterestquerybookbefore 3.14.23.14.2Patch availableCNA
  • querybook Vendorpinterest Affected before 3.14.2 Fixed in 3.14.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pinterest:querybook:*:*:*:*:*:*:*:*before 3.14.2Vulnerablepinterest
  • cpe:2.3:a:pinterest:querybook:*:*:*:*:*:*:*:* Versions before 3.14.2 Vulnerable ·pinterest

Remediation

  • Fix · CNA querybook (pinterest) Fixed in 3.14.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-46151

References

  • TI-2024-17238 Querybook's Stored Cross-Site Scripting vulnerability allows Privilege Elevation CVSS 3.1MEDIUM 6.1
  • TI-2024-18810 Cross-site websocket hijacking in Querybook CVSS 3.1HIGH 7.3
  • TI-2024-17964 Querybook Stored Cross-Site Scripting allows Privilege Elevation CVSS 3.1MEDIUM 6.1

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences