Account takeover via prototype vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
NodeBB is an open source Node.js based forum software. Due to a plain object with a prototype being used in socket.io message handling a specially crafted payload can be used to impersonate other users and takeover accounts. This vulnerability has been patched in version 2.6.1. Users are advised to upgrade. Users unable to upgrade may cherry-pick commit `48d143921753914da45926cca6370a92ed0c46b8` into their codebase to patch the exploit.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeBB | NodeBB | before 2.6.1 | 2.6.1 | Patch available | CNA |
| — | nodebb (npm) | before 2.6.1 | 2.6.1 | Patch available | GHSA-rf3g-v8p5-p675 |
- NodeBB VendorNodeBB Affected before 2.6.1 Fixed in 2.6.1 Patch available CNA
- nodebb (npm) Vendor— Affected before 2.6.1 Fixed in 2.6.1 Patch available GHSA-rf3g-v8p5-p675
Remediation
- Fix · CNA NodeBB (NodeBB) Fixed in 2.6.1
- Fix · GHSA-rf3g-v8p5-p675 nodebb (npm) Fixed in 2.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-46164
- 2026-10-03 Alias added: GHSA-rf3g-v8p5-p675
References
Patch 2
More Nodebb vulnerabilities
- TI-2023-23124 A remote code execution (RCE) vulnerability in the xmlrpc.php endpoint of NodeBB Inc… CVSS 3.1CRITICAL 9.8
- TI-2026-42173 NodeBB - ActivityPub Author Spoofing via Unvalidated attributedTo Mapped to Local User CVSS 4.0HIGH 8.7
- TI-2025-32286 NodeBB v4.3.0 is vulnerable to SQL injection in its search-categories API endpoint… CVSS 3.1HIGH 8.6
- TI-2023-14416 NodeBB Pre-Authentication Denial-of-Service CVSS 3.1HIGH 7.5
- TI-2022-16499 Account takeover via SSO plugins in NodeBB CVSS 3.1HIGH 8.8
- TI-2025-21119 Cross-Site Scripting (XSS) vulnerability in NodeBB v4.0.4 and before allows remote… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-46164 · CVE Program
- CVE-2022-46164 · NVD
- FIRST EPSS
- GHSA-rf3g-v8p5-p675 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences