Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many…
Priority MEDIUM 42CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.
Summary
Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00879 59th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hasura:graphql_engine:*:*:*:*:*:*:*:* | 2.10.0 to before 2.10.2; 2.11.0 to before 2.11.3; 2.13.0 to before 2.13.2; 2.15.0 to before 2.15.2 | Vulnerable | Hasura |
| cpe:2.3:a:hasura:graphql_engine:2.12.0:-:*:*:*:*:*:* | 2.12.0 | Vulnerable | Hasura |
| cpe:2.3:a:hasura:graphql_engine:2.12.0:beta1:*:*:*:*:*:* | 2.12.0 beta1 | Vulnerable | Hasura |
| cpe:2.3:a:hasura:graphql_engine:2.14.0:-:*:*:*:*:*:* | 2.14.0 | Vulnerable | Hasura |
| cpe:2.3:a:hasura:graphql_engine:2.14.0:beta1:*:*:*:*:*:* | 2.14.0 beta1 | Vulnerable | Hasura |
| cpe:2.3:a:hasura:graphql_engine:2.14.0:beta2:*:*:*:*:*:* | 2.14.0 beta2 | Vulnerable | Hasura |
- cpe:2.3:a:hasura:graphql_engine:*:*:*:*:*:*:*:* Versions 2.10.0 to before 2.10.2; 2.11.0 to before 2.11.3; 2.13.0 to before 2.13.2; 2.15.0 to before 2.15.2 Vulnerable ·Hasura
- cpe:2.3:a:hasura:graphql_engine:2.12.0:-:*:*:*:*:*:* Versions 2.12.0 Vulnerable ·Hasura
- cpe:2.3:a:hasura:graphql_engine:2.12.0:beta1:*:*:*:*:*:* Versions 2.12.0 beta1 Vulnerable ·Hasura
- cpe:2.3:a:hasura:graphql_engine:2.14.0:-:*:*:*:*:*:* Versions 2.14.0 Vulnerable ·Hasura
- cpe:2.3:a:hasura:graphql_engine:2.14.0:beta1:*:*:*:*:*:* Versions 2.14.0 beta1 Vulnerable ·Hasura
- cpe:2.3:a:hasura:graphql_engine:2.14.0:beta2:*:*:*:*:*:* Versions 2.14.0 beta2 Vulnerable ·Hasura
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-46792
- 2026-10-03 Alias added: GHSA-jfv6-7jf3-3v86
References
More Hasura Graphql Engine vulnerabilities
- TI-2021-22365 Hasura GraphQL 1.3.3 - Remote Code Execution CVSS 4.0CRITICAL 9.3
- TI-2021-22330 Hasura GraphQL 1.3.3 Denial of Service via Malicious GraphQL Query CVSS 4.0HIGH 8.7
- TI-2021-22331 Hasura GraphQL 1.3.3 Local File Read via SQL Injection CVSS 4.0MEDIUM 6.9
- TI-2023-12298 Unauthenticated path traversal vulnerability in Hasura GraphQL Engine CVSS 3.1HIGH 7.5
- TI-2021-22332 Hasura GraphQL 1.3.3 Server-Side Request Forgery via Remote Schema Injection CVSS 4.0MEDIUM 6.9
- TI-2019-16093 graphql-engine (aka Hasura GraphQL Engine) before 1.0.0-beta.3 mishandles the audience check while verifying JWT. CVSS 3.0HIGH 7.5
Sources
- CVE-2022-46792 · CVE Program
- CVE-2022-46792 · NVD
- FIRST EPSS
- GHSA-jfv6-7jf3-3v86 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences