Read the docs
TI-2022-23169 Aliases CVE-2022-46823GHSA-mqwr-55wx-37jr

Cross-site scripting in Siemens Mendix SAML

Priority MEDIUM 43CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

A vulnerability has been identified in Mendix SAML (Mendix 8 compatible) (All versions >= V2.3.0 < V2.3.4), Mendix SAML (Mendix 9 compatible, New Track) (All versions >= V3.3.0 < V3.3.9), Mendix SAML (Mendix 9 compatible, Upgrade Track) (All versions >= V3.3.0 < V3.3.8). The affected module is vulnerable to reflected cross-site scripting (XSS) attacks. This could allow an attacker to extract sensitive information by tricking users into accessing a malicious link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00483 41st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
SiemensMendix SAML (Mendix 8 compatible)All versions >= V2.3.0 < V2.3.4—No fix listedCNA
SiemensMendix SAML (Mendix 9 compatible, New Track)All versions >= V3.3.0 < V3.3.9—No fix listedCNA
SiemensMendix SAML (Mendix 9 compatible, Upgrade Track)All versions >= V3.3.0 < V3.3.8—No fix listedCNA
  • Mendix SAML (Mendix 8 compatible) VendorSiemens Affected All versions >= V2.3.0 < V2.3.4 Fixed in — No fix listed CNA
  • Mendix SAML (Mendix 9 compatible, New Track) VendorSiemens Affected All versions >= V3.3.0 < V3.3.9 Fixed in — No fix listed CNA
  • Mendix SAML (Mendix 9 compatible, Upgrade Track) VendorSiemens Affected All versions >= V3.3.0 < V3.3.8 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mendix:saml:*:*:*:*:*:*:*:*2.3.0 to before 2.3.4; 3.3.0 to before 3.3.9VulnerableMendix
  • cpe:2.3:a:mendix:saml:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.4; 3.3.0 to before 3.3.9 Vulnerable ·Mendix

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-46823
  2. 2026-10-03 Alias added: GHSA-mqwr-55wx-37jr

References

  • TI-2026-20057 Authentication bypass in Fortinet FortiWeb KEVCVSS 3.1CRITICAL 9.4
  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-18911 Heap-based buffer overflow in Fortinet FortiSwitchManager KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-07142 Code injection in Spring Framework KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
See all 2487 →

Sources