An issue was discovered in the fe_change_pwd (aka Change password for frontend users)…
Priority MEDIUM 42CWE-613Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-613.
Summary
An issue was discovered in the fe_change_pwd (aka Change password for frontend users) extension before 2.0.5, and 3.x before 3.0.3, for TYPO3. The extension fails to revoke existing sessions for the current user when the password has been changed.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0047 40th percentileScored 2026-11-07
Fix Fixed typo3/cms (Packagist): 2.0.5, 3.0.3derhansen/fe_change_pwd (Packagist): 3.0.3, 2.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | typo3/cms (Packagist) | before 2.0.5 | 2.0.5 | Patch available | GHSA-53mm-hx32-6475 |
| — | typo3/cms (Packagist) | 3.0.0 to before 3.0.3 | 3.0.3 | Patch available | GHSA-53mm-hx32-6475 |
| — | derhansen/fe_change_pwd (Packagist) | 3.0.0 to before 3.0.3 | 3.0.3 | Patch available | GHSA-53mm-hx32-6475 |
| — | derhansen/fe_change_pwd (Packagist) | before 2.0.5 | 2.0.5 | Patch available | GHSA-53mm-hx32-6475 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- typo3/cms (Packagist) Vendor— Affected before 2.0.5 Fixed in 2.0.5 Patch available GHSA-53mm-hx32-6475
- typo3/cms (Packagist) Vendor— Affected 3.0.0 to before 3.0.3 Fixed in 3.0.3 Patch available GHSA-53mm-hx32-6475
- derhansen/fe_change_pwd (Packagist) Vendor— Affected 3.0.0 to before 3.0.3 Fixed in 3.0.3 Patch available GHSA-53mm-hx32-6475
- derhansen/fe_change_pwd (Packagist) Vendor— Affected before 2.0.5 Fixed in 2.0.5 Patch available GHSA-53mm-hx32-6475
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:change_password_for_frontend_users_project:change_password_for_frontend_users:*:*:*:*:*:typo3:*:* | before 2.0.5; 3.0.0 to before 3.0.3 | Vulnerable | Change Password For Frontend Users Project |
- cpe:2.3:a:change_password_for_frontend_users_project:change_password_for_frontend_users:*:*:*:*:*:typo3:*:* Versions before 2.0.5; 3.0.0 to before 3.0.3 Vulnerable ·Change Password For Frontend Users Project
Remediation
- Fix · GHSA-53mm-hx32-6475 typo3/cms (Packagist) Fixed in 2.0.5 Advisory →
- Fix · GHSA-53mm-hx32-6475 typo3/cms (Packagist) Fixed in 3.0.3 Advisory →
- Fix · GHSA-53mm-hx32-6475 derhansen/fe_change_pwd (Packagist) Fixed in 3.0.3 Advisory →
- Fix · GHSA-53mm-hx32-6475 derhansen/fe_change_pwd (Packagist) Fixed in 2.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-47406
- 2026-10-03 Alias added: GHSA-53mm-hx32-6475
References
Sources
- CVE-2022-47406 · CVE Program
- CVE-2022-47406 · NVD
- FIRST EPSS
- GHSA-53mm-hx32-6475 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences