Arbitrary Code Execution using the validate function of csaf-validator-lib
Priority LOW 30CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An high privileged attacker may pass crafted arguments to the validate function of csaf-validator-lib of a locally installed Secvisogram in versions < 0.1.0 wich can result in arbitrary code execution and DoS once the users triggers the validation.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00261 17th percentileScored 2026-11-07
Fix Fixed csaf-validator-lib (Secvisogram): 0.1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Secvisogram | csaf-validator-lib | 0.0.0 to before 0.1.0 | 0.1.0 | Patch available | CNA |
- csaf-validator-lib VendorSecvisogram Affected 0.0.0 to before 0.1.0 Fixed in 0.1.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:csaf-validator-lib_project:csaf-validator-lib:*:*:*:*:*:*:*:* | before 0.1.0 | Vulnerable | Csaf-validator-lib Project |
- cpe:2.3:a:csaf-validator-lib_project:csaf-validator-lib:*:*:*:*:*:*:*:* Versions before 0.1.0 Vulnerable ·Csaf-validator-lib Project
Remediation
- Fix · CNA csaf-validator-lib (Secvisogram) Fixed in 0.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-47924
- 2026-10-03 Alias added: GHSA-32w3-98f9-fhjm
References
More Csaf-validator-lib Project Csaf-validator-lib vulnerabilities
- TI-2022-23739 Insufficient Input Validation in the Endpoint of the csaf-validator-service CVSS 3.1HIGH 7.5
Sources
- CVE-2022-47924 · CVE Program
- CVE-2022-47924 · NVD
- FIRST EPSS
- GHSA-32w3-98f9-fhjm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences