Read the docs
TI-2022-23758 Aliases CVE-2022-47945GHSA-p4qr-vq2g-22wp

ThinkPHP Framework before 6.0.14 allows local file inclusion via the lang parameter when…

Priority HIGH 82CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

ThinkPHP Framework before 6.0.14 allows local file inclusion via the lang parameter when the language pack feature is enabled (lang_switch_on=true). An unauthenticated and remote attacker can exploit this to execute arbitrary operating system commands, as demonstrated by including pearcmd.php.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.30237 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed topthink/framework (Packagist): 6.0.14

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—topthink/framework (Packagist)before 6.0.146.0.14Patch availableGHSA-p4qr-vq2g-22wp
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • topthink/framework (Packagist) Vendor— Affected before 6.0.14 Fixed in 6.0.14 Patch available GHSA-p4qr-vq2g-22wp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:thinkphp:thinkphp:*:*:*:*:*:*:*:*before 6.0.14VulnerableThinkPHP
  • cpe:2.3:a:thinkphp:thinkphp:*:*:*:*:*:*:*:* Versions before 6.0.14 Vulnerable ·ThinkPHP

Remediation

  • Fix · GHSA-p4qr-vq2g-22wp topthink/framework (Packagist) Fixed in 6.0.14 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-47945
  2. 2026-10-03 Alias added: GHSA-p4qr-vq2g-22wp

References

  • TI-2019-06557 ThinkPHP before 3.2.4, as used in Open Source BMS v1.1.1 and other products, allows… KEVCVSS 3.1HIGH 8.8
  • TI-2025-32227 An issue in thinkphp3 v.3.2.5 allows a remote attacker to execute arbitrary code via the index.php component CVSS 3.1CRITICAL 9.8
  • TI-2025-32226 An issue in thinkphp v.5.1 allows a remote attacker to execute arbitrary code via the routecheck function CVSS 3.1CRITICAL 9.8
  • TI-2024-32271 A deserialization vulnerability in the component \controller\Index.php of Thinkphp v6.1.3… CVSS 3.1CRITICAL 9.8
  • TI-2024-30031 A deserialization vulnerability in Thinkphp v6.1.3 to v8.0.4 allows attackers to execute arbitrary code. CVSS 3.1CRITICAL 9.8
  • TI-2022-22736 thinkphp 6.0.0~6.0.13 and 6.1.0~6.1.1 contains a deserialization vulnerability. CVSS 3.1CRITICAL 9.8
See all 26 →

Sources