crypto: qcom-rng - fix infinite loop on requests not multiple of WORD_SZ
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-835.
Summary
In the Linux kernel, the following vulnerability has been resolved: crypto: qcom-rng - fix infinite loop on requests not multiple of WORD_SZ The commit referenced in the Fixes tag removed the 'break' from the else branch in qcom_rng_read(), causing an infinite loop whenever 'max' is not a multiple of WORD_SZ. This can be reproduced e.g. by running: kcapi-rng -b 67 >/dev/null There are many ways to fix this without adding back the 'break', but they all seem more awkward than simply adding it back, so do just that. Tested on a machine with Qualcomm Amberwing processor.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19.236 to before 4.19.245; 5.4.187 to before 5.4.196; 5.10.108 to before 5.10.118; 5.15.31 to before 5.15.42; 5.16.17 to before 5.17 | 4.19.245, 5.4.196, 5.10.118, 5.15.42, 5.17 | Patch available | CNA |
| Linux | Linux | 5.17 and later | 4.19.245, 5.4.196, 5.10.118, 5.15.42, 5.17.10, 5.18 | Patch available | CNA |
- Linux VendorLinux Affected 4.19.236 to before 4.19.245; 5.4.187 to before 5.4.196; 5.10.108 to before 5.10.118; 5.15.31 to before 5.15.42; 5.16.17 to before 5.17 Fixed in 4.19.245, 5.4.196, 5.10.118, 5.15.42, 5.17 Patch available CNA
- Linux VendorLinux Affected 5.17 and later Fixed in 4.19.245, 5.4.196, 5.10.118, 5.15.42, 5.17.10, 5.18 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.19.236 to before 4.19.245; 5.4.187 to before 5.4.196; 5.10.108 to before 5.10.118; 5.15.31 to before 5.15.42; 5.17 to before 5.17.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc1:*:*:*:*:*:* | 5.18 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc2:*:*:*:*:*:* | 5.18 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc3:*:*:*:*:*:* | 5.18 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc4:*:*:*:*:*:* | 5.18 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc5:*:*:*:*:*:* | 5.18 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc6:*:*:*:*:*:* | 5.18 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc7:*:*:*:*:*:* | 5.18 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc9:*:*:*:*:*:* | 5.18 rc9 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.19.236 to before 4.19.245; 5.4.187 to before 5.4.196; 5.10.108 to before 5.10.118; 5.15.31 to before 5.15.42; 5.17 to before 5.17.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc1:*:*:*:*:*:* Versions 5.18 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc2:*:*:*:*:*:* Versions 5.18 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc3:*:*:*:*:*:* Versions 5.18 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc4:*:*:*:*:*:* Versions 5.18 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc5:*:*:*:*:*:* Versions 5.18 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc6:*:*:*:*:*:* Versions 5.18 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc7:*:*:*:*:*:* Versions 5.18 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc9:*:*:*:*:*:* Versions 5.18 rc9 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.245, 5.4.196, 5.10.118, 5.15.42, 5.17
- Fix · CNA Linux (Linux) Fixed in 4.19.245, 5.4.196, 5.10.118, 5.15.42, 5.17.10, 5.18
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-48630
- 2026-10-03 Alias added: GHSA-4rpf-4vmp-3hfw
References
Patch 6
- https://git.kernel.org/stable/c/71a89789552b7faf3ef27969b9bc783fa0df3550
- https://git.kernel.org/stable/c/8be06f62b426801dba43ddf8893952a0e62ab6ae
- https://git.kernel.org/stable/c/233a3cc60e7a8fe0be8cf9934ae7b67ba25a866c
- https://git.kernel.org/stable/c/8a06f25f5941c145773204f2f7abef95b4ffb8ce
- https://git.kernel.org/stable/c/05d4d17475d8d094c519bb51658bc47899c175e3
- https://git.kernel.org/stable/c/16287397ec5c08aa58db6acf7dbc55470d78087d
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-48630 · CVE Program
- CVE-2022-48630 · NVD
- FIRST EPSS
- GHSA-4rpf-4vmp-3hfw · GitHub Advisory Database · CC BY 4.0
- CVE-2022-48630 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences