ASoC: ops: Reject out of bounds values in snd_soc_put_volsw()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 5 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: ASoC: ops: Reject out of bounds values in snd_soc_put_volsw() We don't currently validate that the values being set are within the range we advertised to userspace as being valid, do so and reject any values that are out of range.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.15 and later | 4.9.300, 4.14.265, 4.19.228, 5.4.178, 5.10.99, 5.15.22, 5.16.8, 5.17 | Patch available | CNA |
- Linux VendorLinux Affected 3.15 and later Fixed in 4.9.300, 4.14.265, 4.19.228, 5.4.178, 5.10.99, 5.15.22, 5.16.8, 5.17 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.9.300; 4.10 to before 4.14.265; 4.15 to before 4.19.228; 4.20 to before 5.4.178; 5.5 to before 5.10.99; 5.11 to before 5.15.22; 5.16 to before 5.16.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* | 5.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* | 5.17 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.9.300; 4.10 to before 4.14.265; 4.15 to before 4.19.228; 4.20 to before 5.4.178; 5.5 to before 5.10.99; 5.11 to before 5.15.22; 5.16 to before 5.16.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* Versions 5.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* Versions 5.17 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.9.300, 4.14.265, 4.19.228, 5.4.178, 5.10.99, 5.15.22, 5.16.8, 5.17
Red Hat 2 advisories
- RHSA-2022:8267 Released 2022-11-15 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-162.6.1.el9_1
- Red Hat Enterprise Linux AppStream (v. 9) kernel-debug-devel-5.14.0-162.6.1.el9_1, kernel-debug-devel-matched-5.14.0-162.6.1.el9_1, kernel-devel-5.14.0-162.6.1.el9_1 +5
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-5.14.0-162.6.1.el9_1, kernel-5.14.0-162.6.1.el9_1, kernel-abi-stablelists-5.14.0-162.6.1.el9_1 +14
- RHSA-2022:7683 Released 2022-11-08 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 8) kernel-tools-libs-devel-4.18.0-425.3.1.el8
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-425.3.1.el8, kernel-4.18.0-425.3.1.el8, kernel-abi-stablelists-4.18.0-425.3.1.el8 +19
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2022:7683 |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2022:7683 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2022:8267 |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-48738
- 2026-10-03 Alias added: GHSA-wpx5-jrwp-94gj
References
Patch 8
- https://git.kernel.org/stable/c/40f598698129b5ceaf31012f9501b775c7b6e57d
- https://git.kernel.org/stable/c/586ef863c94354a7e00e5ae5ef01443d1dc99bc7
- https://git.kernel.org/stable/c/65a61b1f56f5386486757930069fbdce94af08bf
- https://git.kernel.org/stable/c/68fd718724284788fc5f379e0b7cac541429ece7
- https://git.kernel.org/stable/c/a9394f21fba027147bf275b083c77955864c366a
- https://git.kernel.org/stable/c/9e8895f1b3d4433f6d78aa6578e9db61ca6e6830
- https://git.kernel.org/stable/c/bb72d2dda85564c66d909108ea6903937a41679d
- https://git.kernel.org/stable/c/817f7c9335ec01e0f5e8caffc4f1dcd5e458a4c0
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-48738 · CVE Program
- CVE-2022-48738 · NVD
- FIRST EPSS
- GHSA-wpx5-jrwp-94gj · GitHub Advisory Database · CC BY 4.0
- CVE-2022-48738 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences