mm: don't try to NUMA-migrate COW pages that have other uses
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: mm: don't try to NUMA-migrate COW pages that have other uses Oded Gabbay reports that enabling NUMA balancing causes corruption with his Gaudi accelerator test load: "All the details are in the bug, but the bottom line is that somehow, this patch causes corruption when the numa balancing feature is enabled AND we don't use process affinity AND we use GUP to pin pages so our accelerator can DMA to/from system memory. Either disabling numa balancing, using process affinity to bind to specific numa-node or reverting this patch causes the bug to disappear" and Oded bisected the issue to commit 09854ba94c6a ("mm: do_wp_page() simplification"). Now, the NUMA balancing shouldn't actually be changing the writability of a page, and as such shouldn't matter for COW. But it appears it does. Suspicious. However, regardless of that, the condition for enabling NUMA faults in change_pte_range() is nonsensical. It uses "page_mapcount(page)" to decide if a COW page should be NUMA-protected or not, and that makes absolutely no sense. The number of mappings a page has is irrelevant: not only does GUP get a reference to a page as in Oded's case, but the other mappings migth be paged out and the only reference to them would be in the page count. Since we should never try to NUMA-balance a page that we can't move anyway due to other references, just fix the code to use 'page_count()'. Oded confirms that that fixes his issue. Now, this does imply that something in NUMA balancing ends up changing page protections (other than the obvious one of making the page inaccessible to get the NUMA faulting information). Otherwise the COW simplification wouldn't matter - since doing the GUP on the page would make sure it's writable. The cause of that permission change would be good to figure out too, since it clearly results in spurious COW events - but fixing the nonsensical test that just happened to work before is obviously the CorrectThing(tm) to do regardless.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.9 and later | 5.10.102, 5.15.25, 5.16.11, 5.17 | Patch available | CNA |
- Linux VendorLinux Affected 5.9 and later Fixed in 5.10.102, 5.15.25, 5.16.11, 5.17 Patch available CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.9.1 to before 5.10.102; 5.11 to before 5.15.25; 5.16 to before 5.16.11 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:-:*:*:*:*:*:* | 5.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc4:*:*:*:*:*:* | 5.9 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc5:*:*:*:*:*:* | 5.9 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc6:*:*:*:*:*:* | 5.9 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc7:*:*:*:*:*:* | 5.9 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc8:*:*:*:*:*:* | 5.9 rc8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* | 5.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* | 5.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* | 5.17 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.9.1 to before 5.10.102; 5.11 to before 5.15.25; 5.16 to before 5.16.11 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:-:*:*:*:*:*:* Versions 5.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc4:*:*:*:*:*:* Versions 5.9 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc5:*:*:*:*:*:* Versions 5.9 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc6:*:*:*:*:*:* Versions 5.9 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc7:*:*:*:*:*:* Versions 5.9 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc8:*:*:*:*:*:* Versions 5.9 rc8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* Versions 5.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* Versions 5.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* Versions 5.17 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.102, 5.15.25, 5.16.11, 5.17
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-48797
- 2026-10-03 Alias added: GHSA-8ccr-7w7q-vmr3
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-48797 · CVE Program
- CVE-2022-48797 · NVD
- FIRST EPSS
- GHSA-8ccr-7w7q-vmr3 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-48797 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences