misc: fastrpc: avoid double fput() on failed usercopy
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: misc: fastrpc: avoid double fput() on failed usercopy If the copy back to userland fails for the FASTRPC_IOCTL_ALLOC_DMA_BUFF ioctl(), we shouldn't assume that 'buf->dmabuf' is still valid. In fact, dma_buf_fd() called fd_install() before, i.e. "consumed" one reference, leaving us with none. Calling dma_buf_put() will therefore put a reference we no longer own, leading to a valid file descritor table entry for an already released 'file' object which is a straight use-after-free. Simply avoid calling dma_buf_put() and rely on the process exit code to do the necessary cleanup, if needed, i.e. if the file descriptor is still valid.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.1 and later | 5.4.180, 5.10.101, 5.15.24, 5.16.10, 5.17 | Patch available | CNA |
- Linux VendorLinux Affected 5.1 and later Fixed in 5.4.180, 5.10.101, 5.15.24, 5.16.10, 5.17 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.1 to before 5.4.180; 5.5 to before 5.10.101; 5.11 to before 5.15.24; 5.16 to before 5.16.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* | 5.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* | 5.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* | 5.17 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.1 to before 5.4.180; 5.5 to before 5.10.101; 5.11 to before 5.15.24; 5.16 to before 5.16.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* Versions 5.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* Versions 5.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* Versions 5.17 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.180, 5.10.101, 5.15.24, 5.16.10, 5.17
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-48821
- 2026-10-03 Alias added: GHSA-h4q9-9fhm-542g
References
Patch 5
- https://git.kernel.org/stable/c/4e6fd2b5fcf8e7119305a6042bd92e7f2b9ed215
- https://git.kernel.org/stable/c/a5ce7ee5fcc07583159f54ab4af5164de00148f5
- https://git.kernel.org/stable/c/e4382d0a39f9a1e260d62fdc079ddae5293c037d
- https://git.kernel.org/stable/c/76f85c307ef9f10aa2cef1b1d5ee654c1f3345fc
- https://git.kernel.org/stable/c/46963e2e0629cb31c96b1d47ddd89dc3d8990b34
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-48821 · CVE Program
- CVE-2022-48821 · NVD
- FIRST EPSS
- GHSA-h4q9-9fhm-542g · GitHub Advisory Database · CC BY 4.0
- CVE-2022-48821 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences