ixgbe: fix pci device refcount leak
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: ixgbe: fix pci device refcount leak As the comment of pci_get_domain_bus_and_slot() says, it returns a PCI device with refcount incremented, when finish using it, the caller must decrement the reference count by calling pci_dev_put(). In ixgbe_get_first_secondary_devfn() and ixgbe_x550em_a_has_mii(), pci_dev_put() is called to avoid leak.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.0 and later | 5.4.229, 5.10.164, 5.15.89, 6.1.7, 6.2 | Patch available | CNA |
- Linux VendorLinux Affected 5.0 and later Fixed in 5.4.229, 5.10.164, 5.15.89, 6.1.7, 6.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.0 to before 5.4.229; 5.5 to before 5.10.164; 5.11 to before 5.15.89; 5.16 to before 6.1.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc1:*:*:*:*:*:* | 6.2 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc2:*:*:*:*:*:* | 6.2 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc3:*:*:*:*:*:* | 6.2 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.0 to before 5.4.229; 5.5 to before 5.10.164; 5.11 to before 5.15.89; 5.16 to before 6.1.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc1:*:*:*:*:*:* Versions 6.2 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc2:*:*:*:*:*:* Versions 6.2 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc3:*:*:*:*:*:* Versions 6.2 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.229, 5.10.164, 5.15.89, 6.1.7, 6.2
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 1 product
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-48896
- 2026-10-03 Alias added: GHSA-mf9q-63r7-3j6h
References
Patch 5
- https://git.kernel.org/stable/c/53cefa802f070d46c0c518f4865be2c749818a18
- https://git.kernel.org/stable/c/112df4cd2b09acd64bcd18f5ef83ba5d07b34bf0
- https://git.kernel.org/stable/c/4c93422a54cd6a349988f42e1c6bf082cf4ea9d8
- https://git.kernel.org/stable/c/c49996c6aa03590e4ef5add8772cb6068d99fd59
- https://git.kernel.org/stable/c/b93fb4405fcb5112c5739c5349afb52ec7f15c07
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-48896 · CVE Program
- CVE-2022-48896 · NVD
- FIRST EPSS
- GHSA-mf9q-63r7-3j6h · GitHub Advisory Database · CC BY 4.0
- CVE-2022-48896 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences