net: arcnet: com20020: Fix null-ptr-deref in com20020pci_probe()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-476.
Summary
In the Linux kernel, the following vulnerability has been resolved: net: arcnet: com20020: Fix null-ptr-deref in com20020pci_probe() During driver initialization, the pointer of card info, i.e. the variable 'ci' is required. However, the definition of 'com20020pci_id_table' reveals that this field is empty for some devices, which will cause null pointer dereference when initializing these devices. The following log reveals it: [ 3.973806] KASAN: null-ptr-deref in range [0x0000000000000028-0x000000000000002f] [ 3.973819] RIP: 0010:com20020pci_probe+0x18d/0x13e0 [com20020_pci] [ 3.975181] Call Trace: [ 3.976208] local_pci_probe+0x13f/0x210 [ 3.977248] pci_device_probe+0x34c/0x6d0 [ 3.977255] ? pci_uevent+0x470/0x470 [ 3.978265] really_probe+0x24c/0x8d0 [ 3.978273] __driver_probe_device+0x1b3/0x280 [ 3.979288] driver_probe_device+0x50/0x370 Fix this by checking whether the 'ci' is a null pointer first.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.18 and later | 4.9.305, 4.14.270, 4.19.233, 5.4.183, 5.10.104, 5.15.27, 5.16.13, 5.17 | Patch available | CNA |
- Linux VendorLinux Affected 3.18 and later Fixed in 4.9.305, 4.14.270, 4.19.233, 5.4.183, 5.10.104, 5.15.27, 5.16.13, 5.17 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.18 to before 4.9.305; 4.10 to before 4.14.270; 4.15 to before 4.19.233; 4.20 to before 5.4.183; 5.5 to before 5.10.104; 5.11 to before 5.15.27; 5.16 to before 5.16.13 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* | 5.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* | 5.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* | 5.17 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc4:*:*:*:*:*:* | 5.17 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc5:*:*:*:*:*:* | 5.17 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc6:*:*:*:*:*:* | 5.17 rc6 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.18 to before 4.9.305; 4.10 to before 4.14.270; 4.15 to before 4.19.233; 4.20 to before 5.4.183; 5.5 to before 5.10.104; 5.11 to before 5.15.27; 5.16 to before 5.16.13 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* Versions 5.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* Versions 5.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* Versions 5.17 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc4:*:*:*:*:*:* Versions 5.17 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc5:*:*:*:*:*:* Versions 5.17 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc6:*:*:*:*:*:* Versions 5.17 rc6 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.9.305, 4.14.270, 4.19.233, 5.4.183, 5.10.104, 5.15.27, 5.16.13, 5.17
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-48908
- 2026-10-03 Alias added: GHSA-cp24-c7w4-6gh4
References
Patch 8
- https://git.kernel.org/stable/c/8e3bc7c5bbf87e86e9cd652ca2a9166942d86206
- https://git.kernel.org/stable/c/b1ee6b9340a38bdb9e5c90f0eac5b22b122c3049
- https://git.kernel.org/stable/c/b838add93e1dd98210482dc433768daaf752bdef
- https://git.kernel.org/stable/c/e50c589678e50f8d574612e473ca60ef45190896
- https://git.kernel.org/stable/c/5f394102ee27dbf051a4e283390cd8d1759dacea
- https://git.kernel.org/stable/c/ea372aab54903310756217d81610901a8e66cb7d
- https://git.kernel.org/stable/c/ca0bdff4249a644f2ca7a49d410d95b8dacf1f72
- https://git.kernel.org/stable/c/bd6f1fd5d33dfe5d1b4f2502d3694a7cc13f166d
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-48908 · CVE Program
- CVE-2022-48908 · NVD
- FIRST EPSS
- GHSA-cp24-c7w4-6gh4 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-48908 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences