usb: gadget: uvc: Prevent buffer overflow in setup handler
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-120 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: usb: gadget: uvc: Prevent buffer overflow in setup handler Setup function uvc_function_setup permits control transfer requests with up to 64 bytes of payload (UVC_MAX_REQUEST_SIZE), data stage handler for OUT transfer uses memcpy to copy req->actual bytes to uvc_event->data.data array of size 60. This may result in an overflow of 4 bytes.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.35 and later | 4.9.337, 4.14.303, 4.19.270, 5.4.229, 5.10.161, 5.15.85, 6.0.15, 6.1.1, 6.2 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.35 and later Fixed in 4.9.337, 4.14.303, 4.19.270, 5.4.229, 5.10.161, 5.15.85, 6.0.15, 6.1.1, 6.2 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.35 to before 4.9.337; 4.10 to before 4.14.303; 4.15 to before 4.19.270; 4.20 to before 5.4.229; 5.5 to before 5.10.161; 5.11 to before 5.15.85; 5.16 to before 6.0.15 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:*:*:*:*:*:*:* | 6.1 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.35 to before 4.9.337; 4.10 to before 4.14.303; 4.15 to before 4.19.270; 4.20 to before 5.4.229; 5.5 to before 5.10.161; 5.11 to before 5.15.85; 5.16 to before 6.0.15 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:*:*:*:*:*:*:* Versions 6.1 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.9.337, 4.14.303, 4.19.270, 5.4.229, 5.10.161, 5.15.85, 6.0.15, 6.1.1, 6.2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-48948
- 2026-10-03 Alias added: GHSA-hvf3-fq2g-9gmg
References
Patch 9
- https://git.kernel.org/stable/c/4972e3528b968665b596b5434764ff8fd9446d35
- https://git.kernel.org/stable/c/06fd17ee92c8f1704c7e54ec0fd50ae0542a49a5
- https://git.kernel.org/stable/c/bc8380fe5768c564f921f7b4eaba932e330b9e4b
- https://git.kernel.org/stable/c/b8fb1cba934ea122b50f13a4f9d6fc4fdc43d2be
- https://git.kernel.org/stable/c/c79538f32df12887f110dcd6b9c825b482905f24
- https://git.kernel.org/stable/c/6b41a35b41f77821db24f2d8f66794b390a585c5
- https://git.kernel.org/stable/c/7b1f773277a72f9756d47a41b94e43506cce1954
- https://git.kernel.org/stable/c/d1a92bb8d697f170d93fe922da763d7d156b8841
- https://git.kernel.org/stable/c/4c92670b16727365699fe4b19ed32013bab2c107
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-48948 · CVE Program
- CVE-2022-48948 · NVD
- FIRST EPSS
- GHSA-hvf3-fq2g-9gmg · GitHub Advisory Database · CC BY 4.0
- CVE-2022-48948 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences