iommu/vt-d: Fix PCI device refcount leak in dmar_dev_scope_init()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: iommu/vt-d: Fix PCI device refcount leak in dmar_dev_scope_init() for_each_pci_dev() is implemented by pci_get_device(). The comment of pci_get_device() says that it will increase the reference count for the returned pci_dev and also decrease the reference count for the input pci_dev @from if it is not NULL. If we break for_each_pci_dev() loop with pdev not NULL, we need to call pci_dev_put() to decrease the reference count. Add the missing pci_dev_put() for the error path to avoid reference count leak.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.15 and later | 4.9.335, 4.14.301, 4.19.268, 5.4.226, 5.10.158, 5.15.82, 6.0.12, 6.1 | Patch available | CNA |
- Linux VendorLinux Affected 3.15 and later Fixed in 4.9.335, 4.14.301, 4.19.268, 5.4.226, 5.10.158, 5.15.82, 6.0.12, 6.1 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.15 to before 4.9.335; 4.10 to before 4.14.301; 4.15 to before 4.19.268; 4.20 to before 5.4.226; 5.5 to before 5.10.158; 5.11 to before 5.15.82; 5.16 to before 6.0.12 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:* | 6.1 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:* | 6.1 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:* | 6.1 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc4:*:*:*:*:*:* | 6.1 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc5:*:*:*:*:*:* | 6.1 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc6:*:*:*:*:*:* | 6.1 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc7:*:*:*:*:*:* | 6.1 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.15 to before 4.9.335; 4.10 to before 4.14.301; 4.15 to before 4.19.268; 4.20 to before 5.4.226; 5.5 to before 5.10.158; 5.11 to before 5.15.82; 5.16 to before 6.0.12 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:* Versions 6.1 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:* Versions 6.1 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:* Versions 6.1 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc4:*:*:*:*:*:* Versions 6.1 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc5:*:*:*:*:*:* Versions 6.1 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc6:*:*:*:*:*:* Versions 6.1 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc7:*:*:*:*:*:* Versions 6.1 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.9.335, 4.14.301, 4.19.268, 5.4.226, 5.10.158, 5.15.82, 6.0.12, 6.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49002
- 2026-10-03 Alias added: GHSA-wp5m-wvhw-w3c5
References
Patch 8
- https://git.kernel.org/stable/c/d47bc9d7bcdbb9adc9703513d964b514fee5b0bf
- https://git.kernel.org/stable/c/71c4a621985fc051ab86d3a86c749069a993fcb2
- https://git.kernel.org/stable/c/876d7bfb89273997056220029ff12b1c2cc4691d
- https://git.kernel.org/stable/c/cbdd83bd2fd67142b03ce9dbdd1eab322ff7321f
- https://git.kernel.org/stable/c/a5c65cd56aed027f8a97fda8b691caaeb66d115e
- https://git.kernel.org/stable/c/bdb613ef179ad4bb9d56a2533e9b30e434f1dfb7
- https://git.kernel.org/stable/c/2a8f7b90681472948de172dbbf5a54cd342870aa
- https://git.kernel.org/stable/c/4bedbbd782ebbe7287231fea862c158d4f08a9e3
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49002 · CVE Program
- CVE-2022-49002 · NVD
- FIRST EPSS
- GHSA-wp5m-wvhw-w3c5 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49002 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences