Inclusion of functionality from untrusted control sphere vulnerability in OpenSSL DLL…
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-829.
Summary
Inclusion of functionality from untrusted control sphere vulnerability in OpenSSL DLL component in Synology Drive Client before 3.3.0-15082 allows local users to execute arbitrary code via unspecified vectors.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Synology Drive Client (Synology) Fixed in 3.5.0-16084
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Synology Drive Client — Synology-SA-24:10 Synology Drive Client
6 records Highest priority Priority MEDIUM 1 MEDIUM, 5 LOW
Other records, highest priority first
- TI-2023-29266 Buffer overflow in Synology Drive ClientPriority MEDIUM 42
- TI-2022-24557 Out-of-bounds write in Synology Drive ClientPriority LOW 31
- TI-2022-24555 Sensitive information in log files in Synology Drive ClientPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49038
- 2026-10-03 Alias added: GHSA-9427-wg4q-6gmj
References
Advisory 1
More Synology Drive Client vulnerabilities
- TI-2023-29266 Buffer overflow in Synology Drive Client CVSS 3.1HIGH 8.2
- TI-2022-24557 Out-of-bounds write in Synology Drive Client CVSS 3.1MEDIUM 6.7
- TI-2022-24555 Sensitive information in log files in Synology Drive Client CVSS 3.1MEDIUM 6.5
- TI-2022-24559 Buffer overflow in Synology Drive Client CVSS 3.1MEDIUM 4.4
- TI-2022-24558 Buffer overflow in Synology Drive Client CVSS 3.1MEDIUM 4.4
Sources
- CVE-2022-49038 · CVE Program
- CVE-2022-49038 · NVD
- FIRST EPSS
- GHSA-9427-wg4q-6gmj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences