dm integrity: fix memory corruption when tag_size is less than digest size
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 7 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: dm integrity: fix memory corruption when tag_size is less than digest size It is possible to set up dm-integrity in such a way that the "tag_size" parameter is less than the actual digest size. In this situation, a part of the digest beyond tag_size is ignored. In this case, dm-integrity would write beyond the end of the ic->recalc_tags array and corrupt memory. The corruption happened in integrity_recalc->integrity_sector_checksum->crypto_shash_final. Fix this corruption by increasing the tags array so that it has enough padding at the end to accomodate the loop in integrity_recalc() being able to write a full digest size for the last member of the tags array.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19 and later | 4.19.240, 5.4.190, 5.10.112, 5.15.35, 5.17.4, 5.18 | Patch available | CNA |
- Linux VendorLinux Affected 4.19 and later Fixed in 4.19.240, 5.4.190, 5.10.112, 5.15.35, 5.17.4, 5.18 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.12 to before 4.19.240; 4.20 to before 5.4.190; 5.5 to before 5.10.112; 5.11 to before 5.15.35; 5.16 to before 5.17.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc1:*:*:*:*:*:* | 5.18 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc2:*:*:*:*:*:* | 5.18 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.12 to before 4.19.240; 4.20 to before 5.4.190; 5.5 to before 5.10.112; 5.11 to before 5.15.35; 5.16 to before 5.17.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc1:*:*:*:*:*:* Versions 5.18 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc2:*:*:*:*:*:* Versions 5.18 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.240, 5.4.190, 5.10.112, 5.15.35, 5.17.4, 5.18
Red Hat 3 advisories
- RHSA-2022:7683 Released 2022-11-08 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 8) kernel-tools-libs-devel-4.18.0-425.3.1.el8
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-425.3.1.el8, kernel-4.18.0-425.3.1.el8, kernel-abi-stablelists-4.18.0-425.3.1.el8 +19
- RHSA-2022:5564 Released 2022-07-13 · Red Hat rating Importantkernel security, bug fix, and enhancement update
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-372.16.1.el8_6, kernel-4.18.0-372.16.1.el8_6, kernel-abi-stablelists-4.18.0-372.16.1.el8_6 +19
- Red Hat Enterprise Linux CRB (v. 8) kernel-tools-libs-devel-4.18.0-372.16.1.el8_6
- Red Hat Virtualization 4 Hypervisor for RHEL 8 kernel-devel-4.18.0-372.16.1.el8_6, perf-4.18.0-372.16.1.el8_6
- RHSA-2022:5249 Released 2022-07-01 · Red Hat rating Importantkernel security and bug fix update
- Red Hat CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-70.17.1.el9_0
- Red Hat Enterprise Linux AppStream (v. 9) kernel-debug-devel-5.14.0-70.17.1.el9_0, kernel-debug-devel-matched-5.14.0-70.17.1.el9_0, kernel-devel-5.14.0-70.17.1.el9_0 +5
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-5.14.0-70.17.1.el9_0, kernel-5.14.0-70.17.1.el9_0, kernel-abi-stablelists-5.14.0-70.17.1.el9_0 +14
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2022:7683 |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2022:5249 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:5249 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2022:5564, RHSA-2022:7683 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2022:5249 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2022:5564 |
| Red Hat Virtualization 4 Hypervisor for RHEL 8 | Fixed | RHSA-2022:5564 |
Not affected: 3 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49044
- 2026-10-03 Alias added: GHSA-68xw-82j5-q94c
- 2026-11-05 Affected versions changed · Red Hat
References
Patch 6
- https://git.kernel.org/stable/c/6a95d91c0b315c965198f6ab7dec7c94129e17e0
- https://git.kernel.org/stable/c/7f84c937222944c03f4615ca4742df6bed0e5adf
- https://git.kernel.org/stable/c/cd02b2687d66f0a8e716384de4b9a0671331f1dc
- https://git.kernel.org/stable/c/6b4bf97587ef6c1927a78934b700204920655123
- https://git.kernel.org/stable/c/4d485cf9b609709e45d5113e6e2b1b01254b2fe9
- https://git.kernel.org/stable/c/08c1af8f1c13bbf210f1760132f4df24d0ed46d6
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49044 · CVE Program
- CVE-2022-49044 · NVD
- FIRST EPSS
- GHSA-68xw-82j5-q94c · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49044 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences