KVM: VMX: Prevent RSB underflow before vmenter
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 7 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: KVM: VMX: Prevent RSB underflow before vmenter On VMX, there are some balanced returns between the time the guest's SPEC_CTRL value is written, and the vmenter. Balanced returns (matched by a preceding call) are usually ok, but it's at least theoretically possible an NMI with a deep call stack could empty the RSB before one of the returns. For maximum paranoia, don't allow *any* returns (balanced or otherwise) between the SPEC_CTRL write and the vmenter. [ bp: Fix 32-bit build. ]
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.16.57 to before 3.17; 4.4.168 to before 4.5 | 3.17, 4.5 | Patch available | CNA |
| Linux | Linux | 4.16 and later | 5.18.14, 5.19 | Patch available | CNA |
- Linux VendorLinux Affected 3.16.57 to before 3.17; 4.4.168 to before 4.5 Fixed in 3.17, 4.5 Patch available CNA
- Linux VendorLinux Affected 4.16 and later Fixed in 5.18.14, 5.19 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 5.18.14 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* | 5.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* | 5.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* | 5.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* | 5.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc5:*:*:*:*:*:* | 5.19 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc6:*:*:*:*:*:* | 5.19 rc6 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 5.18.14 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* Versions 5.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* Versions 5.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* Versions 5.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* Versions 5.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc5:*:*:*:*:*:* Versions 5.19 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc6:*:*:*:*:*:* Versions 5.19 rc6 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 3.17, 4.5
- Fix · CNA Linux (Linux) Fixed in 5.18.14, 5.19
Red Hat 3 advisories
- RHSA-2022:8973 Released 2022-12-13 · Red Hat rating Importantkernel security and bug fix update
- Red Hat CodeReady Linux Builder EUS (v.9.0) kernel-tools-libs-devel-5.14.0-70.36.1.el9_0
- Red Hat Enterprise Linux AppStream EUS (v.9.0) kernel-debug-devel-5.14.0-70.36.1.el9_0, kernel-debug-devel-matched-5.14.0-70.36.1.el9_0, kernel-devel-5.14.0-70.36.1.el9_0 +5
- Red Hat Enterprise Linux BaseOS EUS (v.9.0) bpftool-5.14.0-70.36.1.el9_0, kernel-5.14.0-70.36.1.el9_0, kernel-abi-stablelists-5.14.0-70.36.1.el9_0 +14
- RHSA-2022:7683 Released 2022-11-08 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 8) kernel-tools-libs-devel-4.18.0-425.3.1.el8
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-425.3.1.el8, kernel-4.18.0-425.3.1.el8, kernel-abi-stablelists-4.18.0-425.3.1.el8 +19
- RHSA-2022:7110 Released 2022-10-25 · Red Hat rating Importantkernel security, bug fix, and enhancement update
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-372.32.1.el8_6, kernel-4.18.0-372.32.1.el8_6, kernel-abi-stablelists-4.18.0-372.32.1.el8_6 +19
- Red Hat Enterprise Linux CRB (v. 8) kernel-tools-libs-devel-4.18.0-372.32.1.el8_6
- Red Hat Virtualization 4 Hypervisor for RHEL 8 kernel-devel-4.18.0-372.32.1.el8_6, perf-4.18.0-372.32.1.el8_6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2022:7683 |
| Red Hat CodeReady Linux Builder EUS (v.9.0) | Fixed | RHSA-2022:8973 |
| Red Hat Enterprise Linux AppStream EUS (v.9.0) | Fixed | RHSA-2022:8973 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2022:7110, RHSA-2022:7683 |
| Red Hat Enterprise Linux BaseOS EUS (v.9.0) | Fixed | RHSA-2022:8973 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2022:7110 |
| Red Hat Virtualization 4 Hypervisor for RHEL 8 | Fixed | RHSA-2022:7110 |
Not affected: 2 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49610
- 2026-10-03 Alias added: GHSA-4w6c-74px-57rx
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49610 · CVE Program
- CVE-2022-49610 · NVD
- FIRST EPSS
- GHSA-4w6c-74px-57rx · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49610 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences