can: gs_usb: gs_usb_open/close(): fix memory leak
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: can: gs_usb: gs_usb_open/close(): fix memory leak The gs_usb driver appears to suffer from a malady common to many USB CAN adapter drivers in that it performs usb_alloc_coherent() to allocate a number of USB request blocks (URBs) for RX, and then later relies on usb_kill_anchored_urbs() to free them, but this doesn't actually free them. As a result, this may be leaking DMA memory that's been used by the driver. This commit is an adaptation of the techniques found in the esd_usb2 driver where a similar design pattern led to a memory leak. It explicitly frees the RX URBs and their DMA memory via a call to usb_free_coherent(). Since the RX URBs were allocated in the gs_can_open(), we remove them in gs_can_close() rather than in the disconnect function as was done in esd_usb2. For more information, see the 928150fad41b ("can: esd_usb2: fix memory leak").
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.16 and later | 4.9.323, 4.14.288, 4.19.252, 5.4.205, 5.10.130, 5.15.54, 5.18.11, 5.19 | Patch available | CNA |
- Linux VendorLinux Affected 3.16 and later Fixed in 4.9.323, 4.14.288, 4.19.252, 5.4.205, 5.10.130, 5.15.54, 5.18.11, 5.19 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.16 to before 4.9.323; 4.10 to before 4.14.288; 4.15 to before 4.19.252; 4.20 to before 5.4.205; 5.5 to before 5.10.130; 5.11 to before 5.15.54; 5.16 to before 5.18.11 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* | 5.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* | 5.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* | 5.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* | 5.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc5:*:*:*:*:*:* | 5.19 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.16 to before 4.9.323; 4.10 to before 4.14.288; 4.15 to before 4.19.252; 4.20 to before 5.4.205; 5.5 to before 5.10.130; 5.11 to before 5.15.54; 5.16 to before 5.18.11 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* Versions 5.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* Versions 5.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* Versions 5.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* Versions 5.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc5:*:*:*:*:*:* Versions 5.19 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.9.323, 4.14.288, 4.19.252, 5.4.205, 5.10.130, 5.15.54, 5.18.11, 5.19
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49661
- 2026-10-03 Alias added: GHSA-fw87-5p3g-2r3p
References
Patch 8
- https://git.kernel.org/stable/c/339fa9f80d3b94177a7a459c6d115d3b56007d5a
- https://git.kernel.org/stable/c/c1d806bc29ff7ffe0e2a023583c8720ed96cb0b0
- https://git.kernel.org/stable/c/d91492638b054f4a359621ef216242be5973ed6b
- https://git.kernel.org/stable/c/6f655b5e13fa4b27e915b6c209ac0da74fd75963
- https://git.kernel.org/stable/c/d0b8e223998866b3e7b2895927d4e9689b0a80d8
- https://git.kernel.org/stable/c/0e60230bc64355c80abe993d1719fdb318094e20
- https://git.kernel.org/stable/c/ffb6cc6601ec7c8fa963dcf76025df4a02f2cf5c
- https://git.kernel.org/stable/c/2bda24ef95c0311ab93bda00db40486acf30bd0a
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49661 · CVE Program
- CVE-2022-49661 · NVD
- FIRST EPSS
- GHSA-fw87-5p3g-2r3p · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49661 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences