dm raid: fix KASAN warning in raid5_add_disks
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 5 fixed, 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: dm raid: fix KASAN warning in raid5_add_disks There's a KASAN warning in raid5_add_disk when running the LVM testsuite. The warning happens in the test lvconvert-raid-reshape-linear_to_raid6-single-type.sh. We fix the warning by verifying that rdev->saved_raid_disk is within limits.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.15 and later | 4.9.322, 4.14.287, 4.19.251, 5.4.204, 5.10.129, 5.15.53, 5.18.10, 5.19 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.15 and later Fixed in 4.9.322, 4.14.287, 4.19.251, 5.4.204, 5.10.129, 5.15.53, 5.18.10, 5.19 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.9.322; 4.10 to before 4.14.287; 4.15 to before 4.19.251; 4.20 to before 5.4.204; 5.5 to before 5.10.129; 5.11 to before 5.15.53; 5.16 to before 5.18.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* | 5.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* | 5.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* | 5.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* | 5.19 rc4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.9.322; 4.10 to before 4.14.287; 4.15 to before 4.19.251; 4.20 to before 5.4.204; 5.5 to before 5.10.129; 5.11 to before 5.15.53; 5.16 to before 5.18.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* Versions 5.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* Versions 5.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* Versions 5.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* Versions 5.19 rc4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.9.322, 4.14.287, 4.19.251, 5.4.204, 5.10.129, 5.15.53, 5.18.10, 5.19
Red Hat 2 advisories
- RHSA-2022:8267 Released 2022-11-15 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-162.6.1.el9_1
- Red Hat Enterprise Linux AppStream (v. 9) kernel-debug-devel-5.14.0-162.6.1.el9_1, kernel-debug-devel-matched-5.14.0-162.6.1.el9_1, kernel-devel-5.14.0-162.6.1.el9_1 +5
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-5.14.0-162.6.1.el9_1, kernel-5.14.0-162.6.1.el9_1, kernel-abi-stablelists-5.14.0-162.6.1.el9_1 +14
- RHSA-2022:7683 Released 2022-11-08 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 8) kernel-tools-libs-devel-4.18.0-425.3.1.el8
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-425.3.1.el8, kernel-4.18.0-425.3.1.el8, kernel-abi-stablelists-4.18.0-425.3.1.el8 +19
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2022:7683 |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2022:7683 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2022:8267 |
Not affected: 1 product
- Red Hat Enterprise Linux 10
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49673
- 2026-10-03 Alias added: GHSA-q593-ph6q-rmqf
References
Patch 8
- https://git.kernel.org/stable/c/2d4e7c9898c20fb3d3f55381cab601761aab7d64
- https://git.kernel.org/stable/c/2fb2928728038280bd925ce2aafb4997e9d47ee9
- https://git.kernel.org/stable/c/3553a69bb52be2deba61d0ca064c41aee842bb35
- https://git.kernel.org/stable/c/f157bd9cf377a947fdb7035e69466b6ecdc17c17
- https://git.kernel.org/stable/c/d8bca518d5272fe349e0a722fdb9e3acb661f3f0
- https://git.kernel.org/stable/c/d5b06039b195d4b6f94f5d345b1e4ac1975a9832
- https://git.kernel.org/stable/c/02cffb1921edadd9b6e4eee7ada4a5213e8ba12e
- https://git.kernel.org/stable/c/617b365872a247480e9dcd50a32c8d1806b21861
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49673 · CVE Program
- CVE-2022-49673 · NVD
- FIRST EPSS
- GHSA-q593-ph6q-rmqf · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49673 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences