usb: gadget: lpc32xx_udc: Fix refcount leak in lpc32xx_udc_probe
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: usb: gadget: lpc32xx_udc: Fix refcount leak in lpc32xx_udc_probe of_parse_phandle() returns a node pointer with refcount incremented, we should use of_node_put() on it when not need anymore. Add missing of_node_put() to avoid refcount leak. of_node_put() will check NULL pointer.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.5 and later | 4.9.320, 4.14.285, 4.19.249, 5.4.200, 5.10.124, 5.15.49, 5.18.6, 5.19 | Patch available | CNA |
- Linux VendorLinux Affected 3.5 and later Fixed in 4.9.320, 4.14.285, 4.19.249, 5.4.200, 5.10.124, 5.15.49, 5.18.6, 5.19 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.5 to before 4.9.320; 4.10 to before 4.14.285; 4.15 to before 4.19.249; 4.20 to before 5.4.200; 5.5 to before 5.10.124; 5.11 to before 5.15.49; 5.16 to before 5.18.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* | 5.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* | 5.19 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.5 to before 4.9.320; 4.10 to before 4.14.285; 4.15 to before 4.19.249; 4.20 to before 5.4.200; 5.5 to before 5.10.124; 5.11 to before 5.15.49; 5.16 to before 5.18.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* Versions 5.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* Versions 5.19 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.9.320, 4.14.285, 4.19.249, 5.4.200, 5.10.124, 5.15.49, 5.18.6, 5.19
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49712
- 2026-10-03 Alias added: GHSA-q72h-v66c-fgvw
References
Patch 8
- https://git.kernel.org/stable/c/d85e4e6284a91aa2d1ab004e9d84b9c09b4aa203
- https://git.kernel.org/stable/c/0ef6917c0524da5b88496b9706628ffef108b9bb
- https://git.kernel.org/stable/c/2a598da14856ead80c726b38ba426c68637d9211
- https://git.kernel.org/stable/c/b75bddfcc18170ce8e3fb695a76ec2dec4ce0ea5
- https://git.kernel.org/stable/c/57901c658f77d9ea2e772f35cb38e47efb54c558
- https://git.kernel.org/stable/c/46da1e4a8b6329479433b2a4056941dfdd7f3efd
- https://git.kernel.org/stable/c/727c82d003e0ec64411fd1257a9a57de4ad7a99a
- https://git.kernel.org/stable/c/4757c9ade34178b351580133771f510b5ffcf9c8
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49712 · CVE Program
- CVE-2022-49712 · NVD
- FIRST EPSS
- GHSA-q72h-v66c-fgvw · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49712 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences